LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-06-2008, 07:22 AM   #1
tovis
Member
 
Registered: Jan 2007
Location: Budapest
Distribution: Debian
Posts: 74

Rep: Reputation: 15
[SOLVED] courierfax


Debian Etch SOHO server, no X.
I have managed to install and setup/configure mgetty+sendfax - checked sending/receiving from shell.
I have managed to install setup/configure courier-mta using smarthost and courier-imap, with simply using pam authentication - checked, using squirrelmail on apache2 and fetchmail as mail delivery from different providers, I can send receive mails. The only quirk was smarthost configuration of courier, which is fall to create file under, courier's configuration directory /etc/courier/smtproute contain one row with smarthost domain ":smarthost.com".
I'm stucked on faxing, courier has courier faxmail capability which should be configured through /etc/courier/faxrc - unfortunatelly it has no default, some what working version, and is it about strange conversions around dialing numbers. After, markout first line with "rw^" , as suggested in faxrc itself I'm tried to fax, using usual 7 digits hungarian phone number, expand it to 10 digit using international area code (361 - Budapest) but I always has the same SMTP error:
513 - invalid domain name. The senders domain should be good, it is working for E-mails, nothing left, that 1234567@fax or 3611234567@fax is wrong.
Some one have a correct working configuration for example?

Last edited by tovis; 03-08-2008 at 06:50 AM. Reason: problem is solved
 
Old 03-08-2008, 06:55 AM   #2
tovis
Member
 
Registered: Jan 2007
Location: Budapest
Distribution: Debian
Posts: 74

Original Poster
Rep: Reputation: 15
README.Debian for courier is talk about that root should enable faxing, and after talking about /etc/courier/faxrc which must be adited for this. But also need a FAXRELAYCLIENT entry at smtpaccess/smtpaccess.dat.
After installation I have an /etc/courier/smtpaccess/default file and an apropriate /etc/courier/smtpaccess.dat file, need to expand entry for localhost in /etc/courier/smtpaccess/default

127.0.0.1<TAB>allow,RELAYCLIENT,FAXRELAYCLIENT

run #makesmtpaccess
and voila, faxing is start working
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration