LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-17-2008, 11:46 AM   #1
hessond
LQ Newbie
 
Registered: Jan 2008
Location: Florida US
Distribution: Fedora8, Ubuntu
Posts: 18

Rep: Reputation: 0
Unhappy Connecting to LDAP server


Hello -

Can someone point me to a good tutorial for connecting to an LDAP server, please.

I am currently using Fedora 8, and have MediaWiki installed and working on the machine. My ultimate goal is to have MediaWiki users locally log into MW using LDAP Authentication.

I'm stuck in neutral right now, and appreciate any direction you might share.

Thanks,
D
 
Old 03-18-2008, 04:55 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977
well the standard docs really are a better first point of call - http://www.mediawiki.org/wiki/Extens...Authentication if you have specific issues, please ask again. also worth cutting the issue in half and ensuring you can comfortably do ldapsearch calls against the ldap service before moving over into mediawiki configs as well.
 
Old 03-18-2008, 07:27 AM   #3
hessond
LQ Newbie
 
Registered: Jan 2008
Location: Florida US
Distribution: Fedora8, Ubuntu
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you, Chris for your reply.

You are absolutely correct. I should have had ldap setup complete before trying MW connection. Yes, I have been through the MW docs.

I really did mess up big-time, however, and do have some specific questions. (I am quite new, but I'm forging ahead)

A few days ago, I made some changes to the GUI Network Administration panel. Since that time, eth0 is disabled at boot, and I must manually enable eth0 each time I reboot. (I thought it a minor inconvenience, and I would figure out a fix for that later...)

For ldap, I followed the directions here:
http://www.yolinux.com/TUTORIALS/LDA...ntication.html
to connect to an ldap server. The last direction was to reboot to enable ldap. Which I did. (How dumb!)

You can see the problem that resulted: authenticate using the network, but no working network.

I can log in as root, but now, I don't know how to enable eth0.

ifconfig eth0 returns

Link encap: Ethernet HWaddr 00:08:02040:7E:7D
BROADCAST MULTICAST MTU:1500 Metric: 1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RXbytes:0 (0.0 b) TX bytes:0 (0.0 b)

What is the location of the file for enabling eth0 ?
Second, assuming ldap is not working correctly when I do reboot, how can I disable ldap using command line?

Thanks for any assistance you might be able to provide. (um... read that, "Help me, please!!!")

Best,
D
 
Old 03-18-2008, 07:43 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977Reputation: 1977
this thread is for an ldap / mediawiki issue, not a network configuration issue. ask that in a new thread.

as for stopping ldap... "service slapd stop"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LDAP: Can't contact master ldap server rulirahm Linux - Networking 2 07-14-2014 02:02 AM
how to connect my proxy server with the local LDAP server ankuraggarwal Linux - Software 0 08-31-2007 02:17 AM
authenticating through one ldap server that uses other ldap servers & active director dreamm Linux - Server 1 02-21-2007 08:22 AM
LDAP server not starting as user LDAP klnasveschuk Fedora 1 02-15-2007 04:49 AM
how do I move ldap database from old server to new server. gcarlisle Linux - General 1 10-07-2006 11:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration