LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Conflicts, dependencies: PostgreSQL 8.2.3 on RHEL4 / U4 (https://www.linuxquestions.org/questions/linux-server-73/conflicts-dependencies-postgresql-8-2-3-on-rhel4-u4-549496/)

makyo 04-27-2007 10:40 AM

Conflicts, dependencies: PostgreSQL 8.2.3 on RHEL4 / U4 [SOLVED]
 
Hi.

PostgreSQL 8.2.3 downloaded RPMs
RedHat Enterprise Linux 4, Update 4
SunFire hardware

I arranged the RPMs to fit the sequence suggested by the pg folks. So the compatibility library is first, etc., in a script that attempts to install all of them.

There is no existing PostgreSQL on the box, although one library is apparently needed by something else (see below).

These are the first few messages from rpm. They cause a cascade of errors later, as one might expect.
Code:

error: Failed dependencies:
        postgresql-libs < 8.1.5 conflicts with compat-postgresql-libs-4-2PGDG.rhel4.i686

warning: postgresql-libs-8.2.3-1PGDG.i686.rpm: V3 DSA signature: NOKEY, key ID 20579f11
error: Failed dependencies:
        libpq.so.3 is needed by (installed) cyrus-sasl-sql-2.1.19-5.EL4.i386

warning: postgresql-8.2.3-1PGDG.i686.rpm: V3 DSA signature: NOKEY, key ID 20579f11
error: Failed dependencies:
        libpq.so.5 is needed by postgresql-8.2.3-1PGDG.i686

I didn't see anything in the brief install guide that mentioned this.

If you have any suggestions on how to deal with this, I'd appreciate hearing them ... cheers, makyo

Lenard 04-28-2007 07:44 AM

Try installing them all at once, from where the rpm packages are located type as root type;

rpm -Uvh *.rpm

Apparently you have a couple of other already installed packages causing these errors, installing multiple packages via a script or by hand can be a problem (Welcome to dependency Hell). Gathering all the packages needed/required in one common location and installing them all at once works better.

makyo 05-04-2007 12:25 PM

Hi, Lenard.

Thanks for the suggestion -- I would not have guessed that rpm would have a gestalt-like feature to do the re-arranging of rpms to satisfy dependencies, but that is a useful feature.

So I did that, and rpm suggested that I install a package mx. I did that with up2date. It was successful.

I then tried to install postgreSQL again, and got:
Code:

# rpm -Uvh *.rpm
warning: postgresql-8.2.3-1PGDG.i686.rpm: V3 DSA signature: NOKEY, key ID 20579f11
error: Failed dependencies:
        libpq.so.3 is needed by (installed) cyrus-sasl-sql-2.1.19-5.EL4.i38

Is this the beginning of dependency hell for me?

Any further solutions come to mind? ... cheers, makyo

Lenard 05-04-2007 04:53 PM

Sorry it is beginning to look that way, as a suggestion try downloading the latest versions. for example I download the RHEL5 version packages:

$ ls post*
postgresql-8.2.4-1PGDG.x86_64.rpm
postgresql-contrib-8.2.4-1PGDG.x86_64.rpm
postgresql-libs-8.2.4-1PGDG.x86_64.rpm
postgresql-plperl-8.2.4-1PGDG.x86_64.rpm
postgresql-plpython-8.2.4-1PGDG.x86_64.rpm
postgresql-pltcl-8.2.4-1PGDG.x86_64.rpm
postgresql-server-8.2.4-1PGDG.x86_64.rpm

Tested the installation of the packages and got no errors or issues:

$ rpm -Uvh post*.rpm --test
warning: postgresql-8.2.4-1PGDG.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 20579f11
Preparing... ########################################### [100%]

And removing cyrus-sasl-sql if possible: rpm -e cyrus-sasl-sql --test

What I have installed on my system (cyrus packages only) for this test;
$ rpm -qa 'cyrus*'
cyrus-sasl-plain-2.1.22-4
cyrus-sasl-md5-2.1.22-4
cyrus-sasl-lib-2.1.22-4
cyrus-sasl-lib-2.1.22-4
cyrus-sasl-plain-2.1.22-4

makyo 05-06-2007 03:40 PM

Hi, Lenard.

I tried 8.2.4:
Code:

# rpm -Uvh *.rpm
warning: postgresql-8.2.4-1PGDG.i686.rpm: V3 DSA signature: NOKEY, key ID 20579f11
error: Failed dependencies:
        libpq.so.3 is needed by (installed) cyrus-sasl-sql-2.1.19-5.EL4.i386

My cyrus packages:
Code:

# rpm -qa 'cyrus*'
cyrus-sasl-md5-2.1.19-5.EL4
cyrus-sasl-plain-2.1.19-5.EL4
cyrus-sasl-sql-2.1.19-5.EL4
cyrus-sasl-ntlm-2.1.19-5.EL4
cyrus-sasl-gssapi-2.1.19-5.EL4
cyrus-sasl-2.1.19-5.EL

I'm reluctant to remove cyrus-sasl-sql until I know what the possible implications are. I'll look around for that.

Thanks for your time, and let me know if you think of anything ... cheers, makyo

makyo 05-06-2007 03:54 PM

Hi.

There is some information about removing cyrus-sasl to be able to install postgreSQL here -- search for cyrus ... cheers, makyo

makyo 05-06-2007 04:18 PM

Hi.

I erased package cyrus-sasl-sql, and installed pg 8.2.4 without trouble. Of course, I don't know if it runs correctly yet, but this helps move forward.

Thanks for your help Lenard ... cheers, makyo


All times are GMT -5. The time now is 12:57 AM.