-   Linux - Server (
-   -   Conflict problem installing MySQL from rpm (

eypros 01-02-2007 07:09 AM

Conflict problem installing MySQL from rpm
Happy new year to everyone!

Well I am facing a problem with the installation MySQL.

Firstly I tried from source. Something went wrong and though installed
I could not run it. Anyway I couldn't find a solution and used

make unistall to unistall it.

It appeared to be working.

Then I tried rpm:

rpm -Uhv /media/CDRoot/mysql_dynamically/MySQL-client-5.0.27-0.glibc23.i386.rpm

I used it from a CD named CDRoot so that's the name.
Error message said it conflicted with some files:

file /usr/bin/mysql from install of MySQL-client-5.0.27-0.glibc23 conflicts with file from package mysql-5.0.18-2.1

And some other similar messages.

I manually deleted those files but the error message continues!:confused: Am I doing something wrong? I need to update some files to let them know that those files don't exist any more?

How am I going to install MySQL?

Any suggestion welcome!

jschiwal 01-02-2007 07:37 AM

Are you sure you haven't already installed MySQL by rpm earlier. For that message, it probably is in the rpm database. You listed both Fedora and SuSE as your distro. Look in the software manager program and see what it says.

eypros 01-29-2007 01:16 AM

I just wanted to say a delayed thanks to jschiwal!

After all it was installed a previous version of MySQL!

All times are GMT -5. The time now is 08:59 AM.