-   Linux - Server (
-   -   configuring postfix, trying to deliver mail, even local doesn’t arrives (

jstitch 08-03-2010 03:41 PM

configuring postfix, trying to deliver mail, even local doesn’t arrives

I'm trying to configure postfix at my server. The thing is that using an external relayhost (gmail) I can actually send emails from my machine, but if I try to use my local machine (no relayhost), then no mail arrives, even if I try to send email to my own local machine.

Logs don't say any error occurred, so I'm not sure what can be happening... any ideas?

If it's of any use, I use Debian Lenny

here's my file:


# See /usr/share/postfix/ for a commented, more complete version                                                                               
# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
myorigin =

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtp_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
#smtp_tls_CAfile = /etc/postfix/cacert.pem

#smtp_sasl_auth_enable = yes
#smtp_sasl_password_maps = hash:/etc/postfix/sasl/passwd
#smtp_sasl_security_options = noanonymous

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

mydomain = $myorigin
myhostname = hostname.$mydomain
mydestination = $mydomain, $myhostname, localhost.$mydomain, localhost
mynetworks_style = host
#  relayhost = []:587
relayhost =

notify_classes = 2bounce, delay, policy, protocol, resource, software

inet_interfaces = all

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases

mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0

recipient_delimiter = +

html_directory = /usr/share/doc/postfix/html

Heres the output in the logs:


Aug  3 14:36:02 hostname postfix/pickup[22767]: F16E31A3F: uid=1000 from=<jstitch>
Aug  3 14:36:03 hostname postfix/cleanup[22959]: F16E31A3F: message-id=<>
Aug  3 14:36:03 hostname postfix/qmgr[22768]: F16E31A3F: from=<>, size=1596, nrcpt=1 (queue active)
Aug  3 14:36:03 hostname procmail[22962]: Error while writing to "/var/log/procmail"
Aug  3 14:36:03 hostname postfix/local[22961]: F16E31A3F: to=<>, orig_to=<jstitch>, relay=local, delay=1.5, delays=1.5/0.02/0/0.03, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Aug  3 14:36:03 hostname postfix/qmgr[22768]: F16E31A3F: removed

perhaps thar error while writing to var/log/procmail suggests a problem with procmail?

actually /var/log/procmail is an empty file with 640 permissions, owner root, group adm (all other syslog files have that same characteristics)

EricTRA 08-04-2010 12:48 AM


Have a look at these sites. Several test are listed there in order to find what might be wrong. Postfix is only a part of a mail server, namely the MTA, the Mail Transfer Agent. You'll need other tools to route your mail. In these links you'll find what you need.

Kind regards,


jstitch 08-04-2010 09:41 AM

Thank you very much...
Actually, I discovered that the relay_host parameter should have something, since I have an ISP providing me with my IP address and etc...

What I was originally trying to do was to setup a mail server, behind the ISP yes, but without relaying on any other server. But I'm stumbling upon walls and walls, and I decided to relay on gmail for now... I managed to configure everything so I can send messages, which appears to be from my gmail account (unless looking at the source of the email, it happens to show the real data of my server ;) and I guess that tweaking at the From and Reply-To fields in the sent emails would do) and also, now I can manage to receive emails from external servers in to my inbox, so, I guess that would (or must?) do...

Thanks again!

All times are GMT -5. The time now is 09:52 PM.