LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-09-2014, 06:48 PM   #1
sayhello_to_the_world
Member
 
Registered: May 2013
Posts: 228

Rep: Reputation: Disabled
configuring Apache in Opensuse 13.1 - some thing fails


hello

while setting up a lampp on opensuse 13.1 all goes well - but the apache-configuring task fails

see the details:

Code:
linux-70ce:/home/martin #  systemctl start apache2.service
Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
linux-70ce:/home/martin # 
linux-70ce:/home/martin # systemctl status apache2.service
apache2.service - The Apache Webserver
   Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled)
   Active: failed (Result: exit-code) since Mo 2014-03-10 00:29:06 CET; 42s ago
  Process: 15667 ExecStop=/usr/sbin/start_apache2 -D SYSTEMD -DFOREGROUND -k graceful-stop (code=exited, status=1/FAILURE)
  Process: 15649 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -DFOREGROUND -k start (code=exited, status=1/FAILURE)
 Main PID: 15649 (code=exited, status=1/FAILURE)

Mär 10 00:29:06 linux-70ce.site start_apache2[15649]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/de... required)
Mär 10 00:29:06 linux-70ce.site systemd[1]: apache2.service: main process exited, code=exited, status=1/FAILURE
Mär 10 00:29:06 linux-70ce.site start_apache2[15667]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/de... required)
Mär 10 00:29:06 linux-70ce.site systemd[1]: apache2.service: control process exited, code=exited status=1
Mär 10 00:29:06 linux-70ce.site systemd[1]: Failed to start The Apache Webserver.
Mär 10 00:29:06 linux-70ce.site systemd[1]: Unit apache2.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
linux-70ce:/home/martin #

well all fails - what do you advice
 
Old 03-09-2014, 07:00 PM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,921

Rep: Reputation: Disabled
My advice would be to...
Quote:
Originally Posted by sayhello_to_the_world View Post
Code:
Mär 10 00:29:06 linux-70ce.site start_apache2[15649]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/de... required)
...take a closer look at line 179 of httpd.conf, perhaps?

It seems to refer to line 102 of some other file, but unfortunately it seems the program generating the output above saw fit to truncate the entry.
 
1 members found this post helpful.
Old 03-10-2014, 12:24 PM   #3
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,657

Rep: Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911
Quote:
Originally Posted by sayhello_to_the_world View Post
hello
while setting up a lampp on opensuse 13.1 all goes well - but the apache-configuring task fails see the details:
Code:
linux-70ce:/home/martin #  systemctl start apache2.service
Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.

Mär 10 00:29:06 linux-70ce.site start_apache2[15649]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/de... required)
Hint: Some lines were ellipsized, use -l to show in full.
well all fails - what do you advice
Did you read and understand what you posted??? The message is VERY clear...it tells you what line of what file has a problem, and even gives you the command to run to show you other dependency lines (the -l flag, so you can see where line 102 leads??)

You did not 'configure' Apache...you tried to START it. Configuring it requires that you modify the configuration file(s) to suit you. So, go do it...pay particular attention to line 179, WHERE THE SYSTEM TOLD YOU THE PROBLEM WAS.
 
Old 03-11-2014, 05:33 AM   #4
sayhello_to_the_world
Member
 
Registered: May 2013
Posts: 228

Original Poster
Rep: Reputation: Disabled
hi There

thx alot for the replies

will have a closer look!
Quote:
Originally Posted by TB0ne View Post
Did you read and understand what you posted??? The message is VERY clear...it tells you what line of what file has a problem, and even gives you the command to run to show you other dependency lines (the -l flag, so you can see where line 102 leads??)

You did not 'configure' Apache...you tried to START it. Configuring it requires that you modify the configuration file(s) to suit you. So, go do it...pay particular attention to line 179, WHERE THE SYSTEM TOLD YOU THE PROBLEM WAS.
tx again
 
Old 03-11-2014, 09:31 AM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,657

Rep: Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911
Quote:
Originally Posted by sayhello_to_the_world View Post
hi There
thx alot for the replies will have a closer look!
tx again
You're welcome, but AGAIN:
  • Please do some basic research on your own first. Actually reading the error messages is the first step.
  • STOP USING TEXT SPEAK. It's "thanks", not "thx" or 'tx"
 
Old 04-08-2014, 05:01 PM   #6
sayhello_to_the_world
Member
 
Registered: May 2013
Posts: 228

Original Poster
Rep: Reputation: Disabled
hello dear all

finally i did this:
Code:
    inux-70ce:/home/martin # 
    linux-70ce:/home/martin # https://forums.opensuse.org/showthre...ng-fails/page2
    bash: https://forums.opensuse.org/showthre...g-fails/page2: Datei oder Verzeichnis nicht gefunden
    linux-70ce:/home/martin # zypper in -f apache2
    Daten des Repositories laden ...
    Installierte Pakete lesen ...
    Installation von 'apache2-2.4.6-6.15.1.i586' aus Repository 'openSUSE 13.1 OSS Update' wird erzwungen.
    Paketabhängigkeiten auflösen ...

    The following package is going to be reinstalled:
      apache2 

    1 zu installierendes Paket.
    Gesamtgröße des Downloads: 986,1 KiB. Kein zusätzlicher Speicherplatz wird nach dieser Operation belegt oder freigegeben.
    Fortfahren? [j/n/? zeigt alle Optionen] (j): j
    Paket apache2-2.4.6-6.15.1.i586 wird abgerufen                                                                                                 (1/1), 986,1 KiB (  3,3 MiB entpackt)
    Abruf: apache2-2.4.6-6.15.1.i586.rpm .........................................................................................................................[fertig (610,2 KiB/s)]
    (1/1) Installation von: apache2-2.4.6-6.15.1 ...............................................................................................................................[fertig]
    Zusätzliche rpm-Ausgabe:
    /usr/sbin/suexec2: cannot verify root:root 0755 - not listed in /etc/permissions
    Updating /etc/sysconfig/apache2...
    looking for old 2.0 modules to be renamed...
    Done.
but i have no access to localhost

hmm - guess that i have still some configuration-work left.
 
Old 04-08-2014, 05:25 PM   #7
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,921

Rep: Reputation: Disabled
Well, an error in a configuration file isn't going to fix itself no matter how many packages you reinstall.
 
1 members found this post helpful.
Old 04-09-2014, 09:04 AM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,657

Rep: Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911
Quote:
Originally Posted by sayhello_to_the_world View Post
hello dear all
finally i did this:

but i have no access to localhost hmm - guess that i have still some configuration-work left.
Unless you follow the instructions on how to correctly configure things, re-installing is an absolute waste of time. All you did was repeat something you already had installed and working, for no reason. Unless you correct the problems in your configuration file(s), it won't work. Unless you set it up right, it won't work.
 
Old 04-09-2014, 12:36 PM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,517

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
just HOW did you install apache ???

zypper would have auto set things up
but it will be up to YOU to actually configure the httpd.conf file

Code:
su -
zypper in apache2
HOWEVER you really should install the "pattern"
---- SUSE uses "patterns" -----
Code:
su -
zypper in -t pattern lamp_server
the "pattern" will install a YAST control panel for the Apache server
--- USE yast to start and stop Apache
SUSE is Very GUI centric !
most things are EASIER to do using yast than in the terminal



but that will NOT teach you HOW to use this rather complex software
you DO need to do a lot of studying
start with the Apache documentation
http://httpd.apache.org/docs/2.4/

then the PHP docs
http://www.php.net/docs.php

suse uses MarieDB now ( and NOT mysql )
https://mariadb.org/

or uses "postgresql"
http://www.postgresql.org/

expect to need about 3 to 6 months of studying

then there is your CMS
--- beyond the scope of this post

Last edited by John VV; 04-09-2014 at 12:40 PM.
 
Old 04-10-2014, 05:51 AM   #10
sayhello_to_the_world
Member
 
Registered: May 2013
Posts: 228

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Ser Olmy View Post
My advice would be to...

...take a closer look at line 179 of httpd.conf, perhaps?

It seems to refer to line 102 of some other file, but unfortunately it seems the program generating the output above saw fit to truncate the entry.

this might be of importance:

Quote:
Open /etc/apache2/default-server.conf in a text editor and change line 102 to "IncludeOptional" as the error message suggests.
well

btw - sure thing i have to do the changes in the config.
it is a bit tricky: i have to do the changes - but i have to do that in the files where only root has access.
how - should l change the permissions of the file or delete it and create it again... or or or.
sorry for the beginners - quesrtion. but every time i do the changes i get back that the permissions are not enough.....

love to hear from you
 
Old 04-10-2014, 07:31 AM   #11
mddnix
Member
 
Registered: Mar 2013
Distribution: Redhat, Ubuntu
Posts: 540

Rep: Reputation: 153Reputation: 153
Use httpd to check for configuration file.
Code:
# httpd -t
 
Old 04-10-2014, 09:34 AM   #12
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,657

Rep: Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911Reputation: 6911
Quote:
Originally Posted by sayhello_to_the_world View Post
this might be of importance:
Code:
Open /etc/apache2/default-server.conf in a text editor and change line 102 to "IncludeOptional" as the error message suggests.
Yes, along with the OTHER configuration file messages that you have to fix. Re-installing packages is ABSOLUTELY POINTLESS unless you configure them correctly.
Quote:
well
btw - sure thing i have to do the changes in the config. it is a bit tricky: i have to do the changes - but i have to do that in the files where only root has access. how - should l change the permissions of the file or delete it and create it again... or or or.
sorry for the beginners - quesrtion. but every time i do the changes i get back that the permissions are not enough.....
love to hear from you
I find this VERY hard to believe. First, you would not be able to install ANY packages, unless you already have root/sudo access. Want to edit files owned by root? Then either get a sudo shell, run your editor with sudo in front of it, or get the root password, and assume root. And seeing as you've been working with Apache/LAMP since last year, and already know how to change the root passwords:
http://www.linuxquestions.org/questi...ot-4175483510/
http://www.linuxquestions.org/questi...em-4175472608/

...it's odd to think that you suddenly don't know how to edit a file.

If you don't know how to address VERY basic permissions issues like this, I suggest you turn over installation and configuration to the systems administrator, since they would know how to do these things.

Last edited by TB0ne; 04-10-2014 at 09:39 AM.
 
Old 04-18-2014, 12:14 PM   #13
sayhello_to_the_world
Member
 
Registered: May 2013
Posts: 228

Original Poster
Rep: Reputation: Disabled
changed

default-server.conf

to the following lines:

Code:
Include /etc/apache2/conf.d/apache2-manual?conf
IncludeOptional
now we have the following

http://pastebin.com/BrNaueL3

but - despite i have activated the runlevels apache 2 to default and mysql to default (on )

i cannot get any localhost with the browser... why

are there any more tests i can run in terminal - to find out why the apache does not work here?
 
Old 04-18-2014, 12:25 PM   #14
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,517

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
mind you IF you really studied the apache documentation
on setting it up and configuring it
you would be able to figure out what Novell did to the program
On suse you can ONLY!!!!! use suse documentation !!! they do things VERY VERY VERY differently that --- well EVERYONE ELSE

so differently that some sites have SUSE only instructions

if you are trying to fallow some random guide ( or even the OFFICIAL Apache documentation) you will have problems

Novell split up the httpd.conf into a few files

manually editing them is NOT!!!! recommended on SUSE

On SUSE you use "yast" for almost EVERYTHING
the yast gui will auto run all the needed "configuration scripts " that would need to be MANUALLY ran if you manually edit files

set up and configure Apache using the yast gui

suse documentation
http://activedoc.opensuse.org/book/o...he-http-server


DO NOT !!! use the OLD documentation on the OLD!!! SDB doc site
https://en.opensuse.org/SDB:Apache_installation
the OLD docs are for opensuse12

Last edited by John VV; 04-18-2014 at 12:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does Apache require the same thing twice? resetreset Linux - Networking 1 04-02-2012 12:09 PM
apache is going really slow (and restarting it is the only thing that helps) steve51184 Linux - Server 20 01-18-2012 11:04 AM
Strange thing with Apache error: Forbidden... Tamara Linux - Newbie 7 06-14-2005 04:11 AM
Strange thing in Apache log nerdstat Linux - Networking 3 07-19-2004 09:54 AM
I am kinda almost done with Apache. Just one thing though. PenguinMan Linux - Networking 4 10-23-2002 12:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration