Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 04-18-2012, 08:11 PM   #1
LQ Newbie
Registered: Apr 2012
Posts: 10

Rep: Reputation: Disabled
Command "vim" in Debian 6.0

i can not use command "vim" in Debian 6.0 after installed it.any one have any idea will be appreciated. thanks in advance.
Old 04-18-2012, 09:52 PM   #2
Registered: Apr 2007
Distribution: Ubuntu
Posts: 105

Rep: Reputation: 19
Perhaps the vim executable isn't in your path, so it doesn't know where to find it when you type the command.


whereis vim

^ that will check to see if a program named vim is in any of the common locations on your system. If it is, then you need to updated your PATH environment variable so it knows where to find it.

sudo apt-get install -y vim

^ that should install it, but you may have already attempted that.
1 members found this post helpful.
Old 04-18-2012, 09:55 PM   #3
LQ Guru
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,287

Rep: Reputation: 1384Reputation: 1384Reputation: 1384Reputation: 1384Reputation: 1384Reputation: 1384Reputation: 1384Reputation: 1384Reputation: 1384Reputation: 1384
A little more detail might help. After you installed what? Debian? vim? I would expect vim would be installed by default but I don't use Debian so really don't know. so what exactly did you do to "use the vim command"? An example of what you did would probably help someone to help you.
Old 04-19-2012, 02:19 AM   #4
Senior Member
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
nano is installed by default not vim, although if he installed Gnome vim-tiny at the very least should be installed.

apt-cache policy vim will show if it is installed

if not install it
apt-get install vim

note the lack of sudo, because for the millionth time it is NOT enabled by default on Debian,
only Ubuntu and friends use it instead of su.
Old 04-19-2012, 03:29 AM   #5
LQ Newbie
Registered: Apr 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
ok thanks now it works !!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vim: "gww" command mzh Linux - General 2 03-25-2012 06:30 AM
Vi/vim and the "insert-only-one-char" command. stf92 Linux - Newbie 7 12-03-2010 10:16 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
Debian can't find the "make" command when I try to compile my onboard NIC driver JSR_tuxbox Linux - Newbie 30 06-29-2007 06:30 PM
problem with command "modprobe iptables" in the debian server rdr129 Linux - Networking 1 04-22-2006 08:49 AM > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 11:02 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration