-   Linux - Server (
-   -   cifs fedora 6 (

baldur_the_god 02-26-2007 10:04 PM

cifs fedora 6
I am trying to share legal files with through my server. The way I have it set up is my pc has all the stuff and my server is an in between for friends that may need a help file or public domain stuff and my pc. I have it set up so the server is using iptables with firestarter controlling, apache, cifs pc is running xp...but I am to a high degree certain that is has nothing to do with this.

I have it set up so as a part of my website, one who knows the address can backdoor to my pc and through their web browser download and public domain things they would like. It worked great with fc 2 but i have upgraded to 6 and am having immense problems. Right now it can be accessed, but when something is downloaded it comes down 0kb...I have iptables set up the same as it was before...i have tried to set up selinux but that might be the problem...i chown -R apache:apache the files I want to share...the most likely candidate to me is cifs and I do not know enough about it to know where to start...

any help would be much appreciated...or if anyone has a better idea how to do what i am doing that would be appreciated also...


ColinAnderson 08-21-2007 09:27 AM

I've been having the same problem with RHEL5 for months: using CIFS, I can mount a share and look at it's contents, all of the file permissions look alright, but when I try to copy or write anything it just hangs at 0kbps indefinitely. Using RHEL4, with CIFS, I have no problems whatsoever.

If you find a solution let me know, because as yet I've been unsuccessful. :(

baldur_the_god 08-22-2007 05:08 PM

cifs answer
what I found out is that cifs is not able to do url recognition so it is impossible as far as I have found. I have not been able to find any work arounds either. I am not sure what to do to fix it and i cannot find any information about configuring it...

if you figure out a work around or something like that let me know...

zQUEz 08-22-2007 05:15 PM

I am no doubt ignorant to the reason you are trying to do this, so bear with me. Whenever I think of transferring files over the Internet, I think ftp or scp, anything but cifs shares. Is there a reason you can't use this method? Is there an additional benefit to using cifs that I am not aware of?

JSkywalker 08-23-2007 01:31 PM

i think he makes a cifs-share between his server and his PC.
in this way 'sharing' his PC-files on the internet

indeed he does not say if these file are downloaded by FTP, SCP or HTTP

JSkywalker 08-25-2007 02:15 AM

i think its this bug mentioned here:

Because the bug is marked as solved there is also a solution given to this problem

You have to change your config of apache:

<Directory "[ is location of your DocumentRoot..]">
  #Add line below because of problem with cifs
  EnableSendfile Off

and after that restart apache... ;-)

baldur_the_god 08-29-2007 03:31 AM

cifs issue
I will try the bugzilla thing...I have tried many things already and had no success, but I will look into that...

You were correct...I have a lot of files that I keep on my pc for ready access. My server is my gateway to the internet and my http server. I am trying to combine the usage of these to minimize disk usage over my network. If I cannot get the download ability with cifs then I have to have a second harddrive on my server and keep an exact copy of everything on that to access and I have to keep it updated every time I download something. It is quite the little pain in the ass doing it that way! Being able to download from a cifs mount allows my to simplify my life and to save disk space...and i feel more cool!

baldur_the_god 08-29-2007 01:07 PM

cifs thingy
okay, that does indeed work. I am saving a ton of disk space now...I have over a terabyte with no duplication of data...hooray!

I think the second line has very little of an effect...the first one seems to be the key to the issue. it is not a bug though. I understand the issue thoroughly now.

thanks for the help all!


All times are GMT -5. The time now is 10:05 PM.