LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 12-05-2017, 12:20 PM   #1
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Kali, Ubuntu, OpenSuse
Posts: 625

Rep: Reputation: 40
CentOS 7 does not boot


Hi Guys,

This morning I was installing an update on my CentOS 7 server #yum update and for some reason it froze while updating which it also brought down the internet on other computers connected to switch where my CentOS box is connected to. I unplugged the patch cord and the internet came back up on the rest of the system.

I forced shutdown the CentOS7 server and it gets stuck on 'Starting Switch Root...'
I edited the Grub menu and removed 'quit' and 'rhgb' and now it shows the following message under 'Starting Switch Root..' - '2.551376 systemd[1]: Failed to execute /sbin/init, giving up: Input/output error'
Also, after a few minutes the message 'random: crng init done' showed up.

I boot using a recovery CentOS disk. Mounted the root partition and move all files and folders in the 'tmp' folder. Rebooted but had no luck.

Can anyone assist?

Thank you

CentOS 7-1708
i7 16GB RAM 500GB SSD
250GB /
250GB /home
 
Old 12-06-2017, 10:11 AM   #2
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Kali, Ubuntu, OpenSuse
Posts: 625

Original Poster
Rep: Reputation: 40
I researched the issue and some users/admins copied the /sbin/init symbolic link and /sbin/systemd/systemd file from the recovery disk to their system and it solved that issue. I tried that among other things; however, it did not resolve the issue. I read that most users had to do a clean install.
Since I need the server before the weekend, I will re-install the O/S. This is the second time a CENTOS 7 server breaks due to an update. I will try Ubuntu Server.

Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Dual boot CentOs 7/Windows 10 - boot loader not properly configured? teaxtor CentOS 4 11-01-2015 02:00 PM
[SOLVED] Dual Boot Slackware with CentOS using CentOS GRUB frankbell Slackware 9 10-26-2011 12:04 PM
[SOLVED] will Centos boot without /boot/.vmlinuz*.hmac? jg167 Linux - Newbie 1 07-12-2010 08:43 AM
need to dual boot centos 5.1 with xp but centos is already installed. extendedping Linux - Software 4 05-13-2008 09:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 12:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration