-   Linux - Server (
-   -   can't mount via NFS4 (

rmahn 09-09-2009 09:49 AM

can't mount via NFS4
When I try to mount using nfs4, I get no such file or directory.

Fedora 11 on server and client. Both have been updated with the latest updates.

What works:
nfs3 works fine.

What doesn't work:
nfs4. I've tried it from other OSes including Fedora 4, and Fedora 1. I get similar problems, although the actual messages are slightly different.

What I've tried:
Again nfs3 works fine. I had to set specific ports and open them through the firewall, but other than that nfs3 and nfs2 are fine. I've checked the ports for nfs4 and they are open. I've used tcpdump to verify that the networking communication is correct. I've turned off the firewalls as well, with no difference. I am not able to find any error logs on either the server or the client. Only an error message after entering the mount command. My gut feel is that either there is a bug in the nfs daemon or I have something wrong in the configuration somewhere, such as the /etc/exports file. I have tried this:
/mountpoint *(sync)
and even that hasn't worked. I've modified /etc/init.d/nfs by removing the restriction on using nfs 4.1. /proc/fs/nfsd/versions shows
+2 +3 +4 +4.1
In almost all these cases, I can use
mount -t nfs host:/mountpoint /mnt
without any problem. But when I change it to
mount -t nfs4 host:/mountpoint /mnt
I get the error:
mount.nfs4: mounting host:/mountpoint failed, reason given by server:
No such file or directory
Exit 32

I haven't seen any other threads on this problem, so I must have something mis-configured, but I can't figure out what it is. Anyone have any suggestions?

cardy 09-09-2009 10:56 AM

Do you have the package


Installed, I have not tried but it may be the mount of an nfs4 share requires the programs below which are provided by this package and my explain why you get a no such file or directory error.


rmahn 09-10-2009 08:09 AM

After more research, I found out the problem. It's that nfs4 has a different paradigm than earlier versions. The basic solution is this:
mount -t nfs4 host:/ /mnt

The nfs4 system uses a single hierarchical tree to export--it isn't capable of exporting multiple separate directories or filesystems. You can use the mount -bind <real_dir> <pseudo_dir> strategy to create a single hierarchical tree with all the directories you want to export, and on the client machines you can mount the desired individual portions of the tree. However, I haven't yet found a way to set up the exports to permit some clients to have access to some portions of the hierarchy and other clients to have access to other portions. So far I've found that any restrictions on the root of the hierarchical tree are carried to all the branches and leaves. It's not a huge problem for my current situation, but it seems that nfs4 would not be very useful for a real "file server" that allocates various filesystems to various groups of users.

cardy 09-10-2009 08:26 AM

I am glad you found a solution I will have to look into nfs4 a little more. I am guessing the nfs4-acl-tools allow you to apply the permissions you require, maybe that will allow you to better define the security permissions (see my last post above)

avalonit 09-10-2009 09:35 AM


I'm happy you found out the nfs4 thing and it will be useful for others. nfs4 also gives you much better support for locking and security control.

I can't understand how the new model is restricting you?


What would be different in nfs3?

All times are GMT -5. The time now is 12:53 PM.