-   Linux - Server (
-   -   Cannot remove printers (

vielmaj 10-27-2010 12:45 PM

Cannot remove printers
I am the administer of a Debian Cluster. In Gnome, I will go to System -> Administration -> Printing, and I cannot delete network printers or edit them. If I try to go to http://localhost:631, anything I do gets a forbidden 403 message. In addition, I will remove cups and reinstall it, and the printers come up automatically.

How do I configure cups to let me edit these printers?

Jason Vielma

jlcasado 10-28-2010 06:14 AM

Dear Jason,

Fast solution:

sudo lpadmin -x <printer_name>

I think you just have a permission issue with your cups configuration (cupsd.conf).

On RHE the file you need to modify is /etc/cups/cupsd.conf and then you need to change several lines:

1) Enable remote access on your browser remotely on /etc/cups/cupsd.conf file:

Listen *:631 ( if you are using local browser then leave the default localhost:631 )

2) Update the groups that has administrative rights over CUPS:

SystemGroup sys root

In our case, we normally create a secondary group (printeradmin) for those users who will manage the printers afterwards.

3) Change permissions by adding the "Allow all" directive to the following sections:

<Location />

Order allow,deny
Allow all </Location>

<Location /admin>

AuthType Basic
Order allow,deny
Allow all </Location>

<Location /admin/conf>

AuthType Basic
Require user @SYSTEM
Order allow,deny
Allow all </Location>

4) Reload cups service:

sudo service cupsd reload

Regarding how to use the GNOME utility, no clue sorry.

Additional documentation:

michaelk 10-28-2010 06:56 AM

If cups is configured for browsing then the local server will automatically add network printers that are shared by other computers also running cups. Browsing can be turned on or off in addition to specifying what network computers to search via cupsd.conf. Sad to say that I have never tried to see if it was possible to change settings on a network printer. I would not expect it to be possible.

vielmaj 10-28-2010 11:30 AM

First I go to System -> Administration -> Printing

then I tried

sudo lpadmin -x <printer_name>

Te printer will disappear and automatically re-appear about 5 seconds.

jlcasado 11-24-2010 04:29 AM


Could you post your cupsd.conf file? Without comments please :)

best regards

sudowtf 11-21-2013 10:53 AM

i had the same issue... solved:

/usr/bin/system-config-printer : Server>Settings: Uncheck "Show printers shared by other systems".

All times are GMT -5. The time now is 11:13 AM.