-   Linux - Server (
-   -   Cannot mount NFS share (wrong fs type, bad option, bad superblock)... (

martinezpt 03-11-2010 08:15 AM

Cannot mount NFS share (wrong fs type, bad option, bad superblock)...

I have a newly installed system (Debian) with an NFS share. The content of the /etc/exports file is:


/discs (insecure, rw, nohide)

I would like to mount this share on another debian machine on the same network. However, whenever I try to mount it the following happens:


server# mount -t nfs backups:/discs /mnt/temp/
mount: wrong fs type, bad option, bad superblock on backups:/discs,
      missing codepage or helper program, or other error
      (for several filesystems (e.g. nfs, cifs) you might
      need a /sbin/mount.<type> helper program)
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

I've searched a lot about this and many people claim that this can be solved by installing nfs-common and portmap. However, these packages are already installed. I've even reinstalled them just to be sure.
I also don't have a "mount.nfs" command.

The strange part is that the "showmount" command correctly identifies the share:


server# showmount -e backups
Export list for backups:
/discs *

Any help would be appreciated

martinezpt 03-11-2010 11:11 AM

Small Update:

I can connect to the NFS share using my Mac. This must mean that the problem is on the client side and not on the server side.

I still can't connect using my other debian machine.

martinezpt 03-12-2010 05:13 AM

I've solved the issue I was having

Just to be sure that the absence of the mount.nfs command was the issue I used strace for the mount command and found the following:


stat64("/sbin/mount.nfs", 0xbff46fa0)  = -1 ENOENT (No such file or directory)
This confirmed that the mount command is indeed calling the mount.nfs which does not exist.

Then I checked and the version of "nfs-common" that apt-get was installing was not the latest one as announced on the debian web site.

So I manually downloaded the nfs-common ".deb" package, solved a dependency for the "libgssglue1" package, installed it and there it was... mount.nfs

Really can't understand why the package downloaded by "apt-get" did not install the command, but it is solved now and that is all that matters to me...

Thank you for trying...

wallybsams 04-25-2010 08:44 PM


Thank you for your post

I had to install ubuntu on one of my machines and it did not install nfs common much to my supprise

I was thinking the problem was on the sever end until I ran across your post

all is well now


All times are GMT -5. The time now is 03:06 PM.