LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 09-09-2008, 03:24 AM   #1
davidmuraya
LQ Newbie
 
Registered: Sep 2008
Location: Nairobi
Distribution: Fedora 9
Posts: 10

Rep: Reputation: 0
Cannot find server name though DNS works


Hi,
I have configured a small zone in Bind 9 for a small intranet.
When I use the nslookup command on a Windows box, it shows
Default server: cannot find server name though it the remote DNS (The Fedora 9 Machine running the bind) resolves the name to IP.
How can I configure it to show
Default Server: server1.example.com
Address: 192.168.XXXXX.XXX

Last edited by davidmuraya; 09-09-2008 at 03:27 AM. Reason: Clarity
 
Old 09-09-2008, 03:51 AM   #2
Woodypecker
Member
 
Registered: Mar 2006
Location: Austria
Distribution: Mandriva/Debian
Posts: 104

Rep: Reputation: 17
How is the windows box receiving the default server?
Most of the time dhcp will do that, so you should configure dhcpd.conf properly.
Otherwise you have to go to (windows box) network-tcpip-properties-advanced-dns tab
and enter your dns server manually.
 
Old 09-09-2008, 03:57 AM   #3
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
is the search path set in the /etc/resolv.conf ?

like on the server

/etc/resolv.conf
search blahfassel.local
nameservers 127.0.0.1

and at the clients
/etc/resolv.conf
search blahfassel.local
nameserver 172.100.1.1


???
 
Old 09-09-2008, 09:19 AM   #4
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Windows nslookup will complain if the DNS server doesn't have a reverse-DNS entry for it's own IP. You need to properly setup the in-addr.arpa zone for your subnet.
 
Old 09-10-2008, 03:20 AM   #5
davidmuraya
LQ Newbie
 
Registered: Sep 2008
Location: Nairobi
Distribution: Fedora 9
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chort View Post
Windows nslookup will complain if the DNS server doesn't have a reverse-DNS entry for it's own IP. You need to properly setup the in-addr.arpa zone for your subnet.
Thanks.

I probably think this is the problem.
I tried inserting reverse dns entries but it kept showing errors ie. NS record not found etc.
Could u post a in-addr.arpa zone
 
Old 09-10-2008, 09:00 AM   #6
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
PHP Code:
$ORIGIN .
$TTL 3600       1 hour
2.22.172
.in-addr.arpa   IN SOA  ns1.smtps.nethostmaster.smtps.net. (
                                
2008081401 serial
                                28800      
refresh (8 hours)
                                
300        retry (5 minutes)
                                
2419200    expire (4 weeks)
                                
3600       minimum (1 hour)
                                )
                        
NS      172.22.2.16.
                        
NS      172.22.2.26.
$ORIGIN 2.22.172.in-addr.arpa.
1                       PTR     dmz-gw.smtps.net.
106                     PTR     gibraltar.smtps.net.
129                     PTR     wifi-gw.smtps.net.
144                     PTR     mle.smtps.net.
149                     PTR     horus2.smtps.net.
16                      PTR     ns1.smtps.net.
213                     PTR     anubis.smtps.net.
26                      PTR     suez.smtps.net.
33                      PTR     giza.smtps.net.
41                      PTR     stlinux.smtps.net.
50                      PTR     am-heh.smtps.net.
6                       PTR     ns2.smtps.net.
70                      PTR     vm-svr-01.smtps.net.
71                      PTR     pps-01.smtps.net.
80                      PTR     tmdemos.smtps.net.
84                      PTR     stdemo.smtps.net.
85                      PTR     mgdemo.smtps.net.
86                      PTR     w2k3-test1.demos.smtps.net.
88                      PTR     pdc-ad.demos.smtps.net.
89                      PTR     vm-obsd.smtps.net.
94                      PTR     dragonflay.smtps.net.
98                      PTR     unbreakable.smtps.net
I just noticed the I'm using IPs for the NS records, and that I have a trailing period. I'm honestly not sure why I did that, normal fully-qualified hostname (with period) should work fine. My reverse zone is working correctly with bind 9.4.x though.
 
Old 09-10-2008, 10:27 AM   #7
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
ok, wonderful, as I see but 1st I guess that you know already that there is a correct reverse zone need.
So did you try what I've told you?
In the DHCP config
the option is domain-name "blahfassel";

I had once exactly this case, and there was a well configured reverse zone as well as a forward zone.
But "nslookups" from the clients failed. So after I've adjusted the dhcp to the above mentioned option it worked.
 
Old 09-12-2008, 04:12 AM   #8
davidmuraya
LQ Newbie
 
Registered: Sep 2008
Location: Nairobi
Distribution: Fedora 9
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chort View Post
PHP Code:
$ORIGIN .
$TTL 3600       1 hour
2.22.172
.in-addr.arpa   IN SOA  ns1.smtps.nethostmaster.smtps.net. (
                                
2008081401 serial
                                28800      
refresh (8 hours)
                                
300        retry (5 minutes)
                                
2419200    expire (4 weeks)
                                
3600       minimum (1 hour)
                                )
                        
NS      172.22.2.16.
                        
NS      172.22.2.26.
$ORIGIN 2.22.172.in-addr.arpa.
1                       PTR     dmz-gw.smtps.net.
106                     PTR     gibraltar.smtps.net.
129                     PTR     wifi-gw.smtps.net.
144                     PTR     mle.smtps.net.
149                     PTR     horus2.smtps.net.
16                      PTR     ns1.smtps.net.
213                     PTR     anubis.smtps.net.
26                      PTR     suez.smtps.net.
33                      PTR     giza.smtps.net.
41                      PTR     stlinux.smtps.net.
50                      PTR     am-heh.smtps.net.
6                       PTR     ns2.smtps.net.
70                      PTR     vm-svr-01.smtps.net.
71                      PTR     pps-01.smtps.net.
80                      PTR     tmdemos.smtps.net.
84                      PTR     stdemo.smtps.net.
85                      PTR     mgdemo.smtps.net.
86                      PTR     w2k3-test1.demos.smtps.net.
88                      PTR     pdc-ad.demos.smtps.net.
89                      PTR     vm-obsd.smtps.net.
94                      PTR     dragonflay.smtps.net.
98                      PTR     unbreakable.smtps.net
I just noticed the I'm using IPs for the NS records, and that I have a trailing period. I'm honestly not sure why I did that, normal fully-qualified hostname (with period) should work fine. My reverse zone is working correctly with bind 9.4.x though.

thanks a bunch!
That was definately the problem!
It is now working perfectly!!!!
Thanks again
It has even become faster in resolving.

Last edited by davidmuraya; 09-12-2008 at 04:20 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Server (bind9) works on the private network but not in the public one! wjleon Linux - Networking 26 01-24-2009 08:14 PM
DNS issue - DNS works perfect on server but not on any other computer jtneal Linux - Networking 3 03-15-2008 03:30 PM
dns works on server, refuses client connections mfleonhardt Linux - Networking 2 01-20-2008 07:19 PM
LXer: Find out DNS Server Version With DNS Server Fingerprinting Tool LXer Syndicated Linux News 0 12-21-2007 05:30 PM
LXer: Find out DNS Server Version With DNS Server Fingeprinting Tool LXer Syndicated Linux News 0 12-21-2007 04:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration