LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 10-26-2007, 06:02 AM   #1
tibberous
Member
 
Registered: Oct 2004
Posts: 56

Rep: Reputation: 15
Can't get PHP 5 to work on CentOS 4.2, Apache 2.0.52


I am trying to setup my VPS and am having a lot of trouble. I setup webmin, and apache was already setup on it. I tried to get mysql setup, but ended up having to use a RPM package.

I downloaded PHP 5, and tried:

./configure --with-mysql

But I get the error:

configure: error: no acceptable cc found in $PATH

The environment variable Path is set to: /usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin

I'm guessing I need to have GCC installed? I tried to install it but can't because of dependencies. Does anyone have any idea how to get this going?

Thanks
 
Old 10-26-2007, 12:37 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
yum install gcc
 
Old 10-26-2007, 09:32 PM   #3
tibberous
Member
 
Registered: Oct 2004
Posts: 56

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Lenard View Post
yum install gcc
I don't have yum =(
 
Old 10-27-2007, 06:25 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Yum is part of CentOS4.2, it is on the installation media or here;

http://dag.wieers.com/rpm/packages/yum/

You will also need these dependencies installed;

Requires: python, rpm-python, rpm >= 0:4.1.1
Requires: python-sqlite, urlgrabber, python-elementtree
Requires: libxml2-python

Again all are on the installation media or at Dag's site, get the el4 versions.
 
  


Reply

Tags
centos4


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i install php to work with apache kiganda Linux - Newbie 1 10-05-2007 06:27 AM
PHP 5.1.0 and Apache 2.0.55 don't work together polemon Linux - Software 8 12-04-2005 12:57 PM
Apache, MySql, PHP work on 10.0 but not 10.1 fireman949 Slackware 3 02-28-2005 11:36 PM
installing php to work with apache citrus Linux - Software 8 04-30-2004 02:08 AM
Can't get PHP and apache to work together FrostGunner Linux - Software 3 09-11-2003 11:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 11:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration