LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 04-08-2007, 03:13 AM   #31
vidurmittal
LQ Newbie
 
Registered: Jun 2006
Posts: 13

Rep: Reputation: 0

pls do the following
pls type http://localhost/cacti/
the above url will solve the problem do put forslash after cacti i hve worked with cacti n always
used http://localhost/cacti/ it has worked always
if this doesn't solve the problem then try method 2 it will work 100%
method

just copy the following lines in ur /etc/httpd/httpd.conf file



<VirtualHost localhostip>
ServerName localhost
DocumentRoot /var/www/html/cacti/
serveralias hostname
</VirtualHost>



now create the entry of the localhost in ur dns server....
it will open at the following address

then http://hostname
or
http://ipaddressofthemachine
 
Old 04-09-2007, 09:24 PM   #32
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
Hey there, i noticed out of common sense that there was problem being showed in the apache error_log when it's started. It says something about php not being able to load something for mysql. I created a test.php file and displayed the phpinfo() output, so the apache-php association is working. I cannot say the same thing about the php-mysql association. So, i read in the cacti forums that i should install mysql-php package, which i did, then i read that also i needed to install php-gd package, which i already did, too. Then i read that i needed to include these extensions into apache and php.ini. But, that person didn't specify how to add those extensions. So perhaps you guys can help me get these extensions in.

How does that sound? If you want, i can put the error message from apache, but i think the problem here is php not working with mysql.

Last edited by trebek; 04-09-2007 at 09:25 PM.
 
Old 04-09-2007, 11:07 PM   #33
treed
Member
 
Registered: Sep 2003
Posts: 45

Rep: Reputation: 15
By package are you referring to the module
because there is a a module for for mysql and php.
Also try writing a php script to connect to a mysql database and see if that works.

Tameika
 
Old 04-10-2007, 02:14 PM   #34
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
I have terrible news!!!!

I installed php-mysql and gd modules. Then added the extensions mysql.so and gd.so to php.ini. Now, mysql won't start. I get this error:
Code:
Starting mysqld daemon with databases from /var/lib/mysql
STOPPING server from pid file /var/run/mysqld/mysqld.pid
070410 13:27:40  mysqld ended


[1]+  Done                    bin/mysqld_safe --user=root
I don't know what happened. Also, before having this problem with mysql, the error in apache was the following:
Code:
<b>Warning</b>:  PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/msql.so' - /usr/lib/php/modules/msql.so: cannot open share
d object file: No such file or directory in <b>Unknown</b> on line <b>0</b><br />
<br />
<b>Warning</b>:  Module 'gd' already loaded in <b>Unknown</b> on line <b>0</b><br />
I am just getting as confused as i've never been before. Has anybody gone through as much trouble as i have with these apps?

Last edited by trebek; 04-10-2007 at 02:17 PM.
 
Old 04-10-2007, 05:44 PM   #35
treed
Member
 
Registered: Sep 2003
Posts: 45

Rep: Reputation: 15
It the path correct it shows msql not mysql?


Tameika
 
Old 04-10-2007, 08:34 PM   #36
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
I got it working again, oddly enough, by removing the mysql server part from add remove programs app that comes with fedora.

Now, i created a test.php file that displays the output of the phpinfo() output. I noticed that among the configure commands, there are a couple of lines that don't include mysql or gd, these lines are: '--without-mysql' '--without-gd'. How can i add, i assume by recompiling php, so that these configure commands are included instead of being displayed as without.

I think that if i get this done, php will work with mysql, and eventually, get cacti to work too.

Here's part of the phpinfo() output that i think is messed up. I have added bold tags around the part that has got me dazzled.

'./configure' '--build=i386-redhat-linux' '--host=i386-redhat-linux' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-pear=/usr/share/pear' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--with-mime-magic=/etc/httpd/conf/magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba'

Last edited by trebek; 04-10-2007 at 08:37 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cacti installation on Debian Sarge: create cacti database error Yahweee Debian 2 08-26-2008 06:35 AM
how to install & configure cacti on Ubuntu linux ketut_hendratha Linux - Newbie 4 08-23-2006 05:30 AM
Slackware guide for AMP Apache MySQL & PHP xushi Slackware 35 05-11-2006 11:18 AM
SElinux & php4 & interbase & apache maxut Linux - Security 0 03-15-2005 04:57 AM
From RedHat9 to FreeBSD (Apache 2 & Mysql & PHP 4) guardian653 *BSD 5 12-11-2003 05:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 11:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration