LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-28-2007, 10:13 PM   #16
lslade
LQ Newbie
 
Registered: Nov 2005
Location: Canada
Distribution: Debian
Posts: 14

Rep: Reputation: 0

In "mysqladmin -u root -p password" there is no space between -p and password.

Sorry, I was out of the country and only checking my mail once a week.

Send me a private message with your email I might be able to help you out. I have a working install of cacti at work.

Last edited by lslade; 03-28-2007 at 10:14 PM.
 
Old 03-29-2007, 10:57 AM   #17
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
I got a message that i cannot send you an email. Mine is available so you can send me one and i'll reply with all i've done.

So, when i type that command, i should not put a space between -p and password? Or is it that i miss it?
 
Old 03-30-2007, 11:14 AM   #18
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
mysql sucks!!!

Hello, i am back. Jjejeje.

As i specified a few posts behind, i installed from source, ran the install_db script from the bin directory and proceeded to assign the security passwords to my root accounts (i deleted the other accounts), as the mysql site manual instructs people should do. So, here's the thing: i started by deleting the anonymous accounts and then typed the following commands:
Code:
[root@penguin2 mysql]# bin/mysqladmin -u root password "mypass";
[root@penguin2 mysql]# bin/mysqladmin -u root -h penguin2.intranet password "mypass";
bin/mysqladmin: connect to server at 'penguin2.intranet' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
As you can notice, as soon as i type the first command, i cannot type the next one, and it's word by word what the mysql site's manual says i should type!!!! Ok, so, i figured that since that command does not include the -p option so you can give a the password to use mysqladmin, i decided to try and tell it to use one so that it can prompt me to type it, so i typed the following:
Code:
[root@penguin2 cacti]# /usr/local/mysql/bin/mysqladmin --user=root -p create cacti
Enter password:
/usr/local/mysql/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: YES)'
As you can see here, i did notice that i specified a password, but would not let me use mysqladmin.

BTW, here's my email since i didn't find where to send you a private email: toolframe@gmail.com

Thanks in advance for the help.

Last edited by trebek; 03-30-2007 at 03:24 PM.
 
Old 03-30-2007, 05:09 PM   #19
treed
Member
 
Registered: Sep 2003
Posts: 45

Rep: Reputation: 15
Okay

When you started mysql in safe mode do that again

1. mysqld_safe --user=root --skip-grant-tables&

Now its time to login
2. mysql -u root

Once logged in you need to set you root passwd:
3. use mysql;

4.UPDATE user SET Password=PASSWORD('new password') WHERE user='root';
exit;

Now you can log in and see if that works if this does then that is great. Now lets grant root some privileges.

Log back in
5. mysql -u root -pnewpassword

Now giving permissions
6. use mysql;
7. GRANT ALL PRIVILEGES ON *.* TO 'root'@'localhost'
IDENTIFIED BY 'some_pass" WITH GRANT OPTION;
8. GRANT ALL PRIVILEGES ON *.* TO 'root'@'%'
IDENTIFIED BY 'some_pass" WITH GRANT OPTION;
9. exit;

Restart mysql daemon

Please note step 8 and 9 work on users that you add to the database.

This should take care of everything root needs.
I have missed some steps could someone back me up on this ?
 
Old 03-31-2007, 05:46 PM   #20
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
Well, i don't know what's going on. The thing is that your advice did work, i got passed the initial steps and managed to add the rest to get cacti setup. So, i go to my browser, and i get a blank screen. Completely and utterly white and blank screen. My god in heaven!!!!!! Any ideas???

BTW, thanks for the help on the past mysql issue. I don't think i would've made it by myself in this lifetime.

U rule dudes!!!!

Last edited by trebek; 04-02-2007 at 02:22 PM.
 
Old 04-04-2007, 03:01 PM   #21
treed
Member
 
Registered: Sep 2003
Posts: 45

Rep: Reputation: 15
Sorry for the late response what port do have set on it.
Where is the index.html file pointing to.

Tameika
 
Old 04-05-2007, 10:55 AM   #22
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
What index.html? And the manual doesn't mention a port should be used.

If you are talking about mysql, the port is the default one. I think it's on my.config in /etc. As for cacti, there is a file in include called config.php where there's a port, and that number is 3306. This port number is the one being used in /etc/my.conf as well.

Now, i am getting another error. I started to guess a little bit and got back to my old initial problem:
Code:
Error

You have created a new database, but have not yet imported the 'cacti.sql' file. At the command line, execute the following to continue:

mysql -u cacti -p cacti < cacti.sql

This error may also be generated if the cacti database user does not have correct permissions on the cacti database. Please ensure that the cacti database user has the ability to SELECT, INSERT, DELETE, UPDATE, CREATE, ALTER, DROP, INDEX on the cacti database.
I followed the instructions in docs/INSTALL to set cacti up. So, i created the database, the script created the tables and stuff, i granted all to the cacti mysql user, gave permissions to the graph and log directories to the cacti system user, etc. It doesn't say i should be doing something else, but certainly, this manual is incomplete.

Thanks for the help and patience. I really appreciate it.

Last edited by trebek; 04-05-2007 at 12:07 PM.
 
Old 04-05-2007, 01:02 PM   #23
treed
Member
 
Registered: Sep 2003
Posts: 45

Rep: Reputation: 15
I belive when you putting your password in from command line there isn't a space.

Give that a shot it should look something like this

mysql -u username -ppassword

Tameika
 
Old 04-05-2007, 02:55 PM   #24
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by treed
I belive when you putting your password in from command line there isn't a space.

Give that a shot it should look something like this

mysql -u username -ppassword

Tameika
I am already passed this point. I can log into mysql, and the database and tables are there too. The problem is when accessing http://localhost/cacti that i get that error as if there is nothing inside the database or that the permissions have not being set up correctly. I assume php is working and that apache is up cause that seems to be an error accessing mysql, not that apache can't process php or that apache is not running. To check, i typed http://localhost to see if apache is running, which it is. How can i verify that php is working properly with apache? Judging by the error message, i think it's gotta do for some strange reason with mysql, or with the cacti config. I have checked and rechecked and redone everything and i still can't get it to run. Here's the error once again:
Code:
Error

You have created a new database, but have not yet imported the 'cacti.sql' file. At the command line, execute the following to continue:

mysql -u cacti -p cacti < cacti.sql

This error may also be generated if the cacti database user does not have correct permissions on the cacti database. Please ensure that the cacti database user has the ability to SELECT, INSERT, DELETE, UPDATE, CREATE, ALTER, DROP, INDEX on the cacti database.
Also, to double check, i performed the following command from within mysql to see the grants on user cacti:
show grants for 'cacti'@'localhost';
This command yielded the following output:
+--------------------------------------------------------------------------------------------------------------+
| Grants for cacti@localhost |
+--------------------------------------------------------------------------------------------------------------+
| GRANT USAGE ON *.* TO 'cacti'@'localhost' IDENTIFIED BY PASSWORD '*8793F1AC6B77776A6642859EA37CD6C1446D01D3' |
| GRANT ALL PRIVILEGES ON `cacti`.* TO 'cacti'@'localhost' WITH GRANT OPTION |
+--------------------------------------------------------------------------------------------------------------+
2 rows in set (0.00 sec)

This certainly looks right! So i don't know why it's not working.

Thanks for the help.

Last edited by trebek; 04-06-2007 at 02:17 PM.
 
Old 04-06-2007, 03:06 PM   #25
treed
Member
 
Registered: Sep 2003
Posts: 45

Rep: Reputation: 15
Did you take a look at this page?

http://cacti.net/downloads/docs/html/faq.html#AEN1862
 
Old 04-06-2007, 05:17 PM   #26
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
Ok, now i am getting a blank screen. I allowed php errors to be displayed, not just logged, and uncommented the line 'extension=mysql.so'. I believe we are almost there. I can't thank you enough dudes.
 
Old 04-07-2007, 06:22 PM   #27
treed
Member
 
Registered: Sep 2003
Posts: 45

Rep: Reputation: 15
Did you grant privileges per hostname?

What is the machine name?

You may want to add that just in case.

Tameika
 
Old 04-07-2007, 07:26 PM   #28
trebek
Member
 
Registered: Feb 2005
Location: Costa Rica
Distribution: Ubuntu, gOS, Debian & Slack 12
Posts: 426

Original Poster
Rep: Reputation: 30
I do have both the hostname and % to make sure i got them. I have cacti@localhost and cacti@% in mysql, with all privileges on the cacti database.

The problem now changed, i have a blank screen instead of the other error message.
 
Old 04-07-2007, 08:34 PM   #29
treed
Member
 
Registered: Sep 2003
Posts: 45

Rep: Reputation: 15
Here is what someone else had to say:

http://cactiusers.org/forums/topic206.html

I didn't look at previous post so I am not sure which version of mysql are you running?


Also do load the php module in the httpd.conf file?

Did you try php somfile.php ?
Check out the errors it may return.

Also someone had a similar problem and they did this:
http://forums.cacti.net/about20513-0-asc-15.html
Look at both pages.

Look hear also
http://forums.cacti.net/about20024.h...t=blank+screen

Also noticed this:
http://forums.cacti.net/about18995.h...t=blank+screen


Hopes this helps!


Tameika
 
Old 04-07-2007, 08:43 PM   #30
treed
Member
 
Registered: Sep 2003
Posts: 45

Rep: Reputation: 15
Also try this page:
http://forums.cacti.net/about18716.h...t=blank+screen

According to a user instead of localhost they put in the ipaddress. Which should be 127.0.0.1.

Tameika
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cacti installation on Debian Sarge: create cacti database error Yahweee Debian 2 08-26-2008 06:35 AM
how to install & configure cacti on Ubuntu linux ketut_hendratha Linux - Newbie 4 08-23-2006 05:30 AM
Slackware guide for AMP Apache MySQL & PHP xushi Slackware 35 05-11-2006 11:18 AM
SElinux & php4 & interbase & apache maxut Linux - Security 0 03-15-2005 04:57 AM
From RedHat9 to FreeBSD (Apache 2 & Mysql & PHP 4) guardian653 *BSD 5 12-11-2003 05:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 05:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration