-   Linux - Server (
-   -   cacti agents (

Lhlalyam 04-13-2007 06:15 PM

cacti agents
Hello Everyone...

I've been working to setup up cacti here on my test server.

I've installed Fedora Core 6 with Cacti-0.8.6j

after installing all the required tools and figuring out how to setup the database, I'm a bit confused in setting up the agents.

The computers I want to identify are Windows Systems. I've enabled the snmp.

This is a guide that I have been following but am not fully certain if it is correct:

Under security: I added a community called cacti and assumed that it should be notify

Under traps: I again added a community called cacti and added the trap destination of my cacti server

When I go to add the system as a device in the Cacti Admin Panel, it informs me that there is an snmp error. I did ensure that it was under the cacti snmp community.

When I look at the settings, nothing shows being created for graphs. I tried different settings.

I am trying to have my Windows XP laptop that is wireless based communicate with the linux cacti server... and i used the settings for Associated Data Queries:


Just to see if anything would show up. Debugging states Verbose Query and Status = Success

my question: How do i get it going for Windows to connect to my cacti server?

acid_kewpie 04-14-2007 02:25 AM

well your best bet is normally to divide the problem in to two, in order to see if it's a cacti issue or a windows issue. use a mib browser, any will do on either windows or linux, and just manually query the device. you'll then be able to see if windows snmp is responding correctly for what you want to be able to obtain. under linux you should already have snmpwalk installed, so try "snmpwalk -v2c -ccacti" where is the windows box and cacti is the community name. if that starts spewing out snmp oids then you're fine from the windows side. often you can have issues in terms of versions of snmp in use. v3 is still rare (and complicated) but v1 and v2c are standard and simple to configure. check you can successfully walk with both versions, that can often be a point of difference.

Lhlalyam 04-15-2007 02:21 PM

Thanx Acid.

I'll see where the configuration problems are. Excellent information you shared. Honestly "ebarrasingly", I hadn't heard of the MIB browser.

I do know that I have SNMPwalk v2 installed on my linux box. It was one of the path requirments needed when I began the install process through the administration panel. I had to use yum to find the location for its "i believe" binary files. Once found, I corrected the path.


Lhlalyam 04-19-2007 04:40 PM

Tried out the snmpwalk command on the linux server to the Windows IP address and it stated that it could not communicate with the requested ip.

So, I checked the snmp agent configuration on the Windows Agent and it all seemed good. So, I checked into the event logs and found the following:

SNMP Event Log Extension Agent has terminated

I also tried the MIB Browser on the Windows agent machine and nothing seem to happen at all. No activity that is.

[EDIT]I also pinged the Server machine from the Windows machine and had success. Still no SNMP though.

would anyone have any other ideas?

acid_kewpie 04-20-2007 02:11 AM

well if would look like an issue within the windows box then, not cacti etc... personal firewall or aynthing?

Lhlalyam 04-20-2007 12:23 PM

I've disabled the firewall but nothing yet. The only difference is that I'm on wireless. I'm not to sure if this makes a difference. Lastly, should community name be the same as a domain or workgroup? or does this really matter?


acid_kewpie 04-20-2007 01:30 PM

well many wireless adsl routers enable some forms of firewalled seperation incase the wireless is compromised, but i'd expect that to cover pings too. and no the community name is irrelevant, just as long as it's the same... it's just a nominal password-like string, (why would you think that an open standard had to relate to a M$ proprietary concept??)

Lhlalyam 04-20-2007 06:56 PM

Ok... I've done some research on the router. It is a WRT54GC. What I did find is that it doesn't accept incoming snmp requests but what I didn't find is if it didn't accept LAN wirless snmp requests.

With the MIB Browser, I received information when I entered the IP Address: with an OID of . and Walk. This was to test if the machine itself could receive SNMP requests.

I also did the IP address which is and an OID of . and this worked also.

When I went to the linux server and did the command:
snmpwalk -v2c -ccacti
I received the following error:
Timeout: No Response from

I also did a simple command of:
An error that came up was:
snmpwalk: Timeout

so, i know snmp is working on the machine, i can only assume it is the router causing this. how would i get around this to make snmp available for the LAN?


acid_kewpie 04-21-2007 03:29 AM

last check would be to see if the server is recieveing the snmp packets. run wireshark on it and look for the incoming packets.

Lhlalyam 05-16-2007 04:08 PM

is wireshark available in text mode only? just curious because my server doesn't use any graphics... text only


acid_kewpie 05-16-2007 04:17 PM

yes, it's called tshark. wireshark comes normally in two packages, wireshark and wireshark-gnome. with just wireshark installed, you don't need X, and only have the tshark command to run in a console. the wireshark-gnome adds the actual wireshark program itself.

bclinton 05-24-2007 10:23 PM


Originally Posted by Lhlalyam
Under security: I added a community called cacti and assumed that it should be notify

Could this be the problem? Try setting the security to 'read only' and see if you can see the computer in Cacti or the MIB browser.

Lhlalyam 06-22-2007 01:09 PM

I tried using tshark on the cacti server with the following commands:

tshark -n -i eth0 -x port 161


tshark -n -i eth1 -x port 161

both came up with the same error:

tshark: the capture session could not be initiated (ioctl: No such device).

I did this command through putty and as root.

I also changed the settings on my windows clients to remove cacti from security but nothing. Any other ideas? Would definitely be nice to get this system going. I've been taking my time at this... as you may note the slow responses by the dates of my posts

acid_kewpie 06-22-2007 02:49 PM

well does eth1 exist? that's clearly what the cited error is.

Lhlalyam 06-22-2007 03:46 PM

I know eth0 shows that it has a fixed IP address as shown in ifconfig. I setup the server with a static ipaddress and it is able to receive updates when I need. I've also started the service snmpd... not to sure if this makes a difference


All times are GMT -5. The time now is 09:38 AM.