LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 01-08-2008, 10:37 PM   #1
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 921

Rep: Reputation: 46
Question Bind9 is interfering with samba


Ladies & Gentlemen.

I am trying to get this set up for fun and the experience. I have read so many how-to's that my brain is in melt down. There is just too much that is beyond me.

Ok I have installed bind9 as per the instructions here http://www.wallpaperama.com/forums/h...dns-t1681.html
I am unsure if my dns is working, caching. One of the instructions says to
Quote:
change the
/etc/network/interfaces and... add gateway 192.168.0.1
I have to comment out the gateway reference to be able to connect to anything.

I only want this dns to be a caching server and I haven't been able to find a suitable how-to for debian to accomplish this. I have found them for Red Hat but the file system and files are to different and i don't know enough about that whole zone thing.

Info about the server: old HP 4440 Debian Etch minimal install with fluxbox. Provides internet service to my network via a usb connected evdo cell phone. I have dhcp installed and working correctly. The internet connection is being shared by firestarter. Firestarter is interfering with samba between my server and the xp host on my network. When that machine is booted into Debian Lenny however firestarter allows the connections fine, but that is not the issue hear.

The other things connected to my network are:
server:disciple (as above)
desktop:rbees (dual xp/lenny upgraded form sarge)
desktop:charles (dual 89/sarge)
printer:brother mfc 5440cn
printer:hp laserjet 4si
laptop:kingbee (dual vista/lenny64)

This network functions correctly.

The instructions I followed didn't have me set up any kind of a data base to store the name resolution results in. I don't see how it can work as a caching server without a place to store the cache. Is this something bind takes care of?

The hosts file. Can I have more than 2 entries in it? Currently it has the 2 servers from my isp and some stuff about IPv6 in it. If I was to put
Code:
192.168.0.1 deciple.torah server
where deciple.torah is the name of my domain, would that be right?

Do I even need a domain name? I have read yes and no. So what is the truth for my setup? It would be nice to use a domain name because of the "cool" factor, but it's not that important.

Next day: DNS is atleast is partially working. I am able to surf. But now I am unable to conect to my samba shares from command line. I am still able to connect from the laptop with smb4k however.

From the laptop I get this
Code:
e:~$ smbclient -L deciples
Error connecting to 63.251.179.32 (Connection refused)
Connection to deciples failed (Error NT_STATUS_CONNECTION_REFUSED)
:~$
I get this from the server
Code:
# smbmount //kingbee/plans /home > /home/data/smb.error
mount.smbfs started (version 3.0.24)
added interface ip=192.168.0.1 bcast=192.168.0.255 nmask=255.255.255.0
resolve_lmhosts: Attempting lmhosts lookup for name kingbee<0x20>
resolve_wins: Attempting wins lookup for name kingbee<0x20>
resolve_wins: WINS server resolution selected and no WINS servers listed.
resolve_hosts: Attempting host lookup for name kingbee<0x20>
Connecting to 63.251.179.32 at port 445
error connecting to 63.251.179.32:445 (Connection refused)
Connecting to 63.251.179.32 at port 139
error connecting to 63.251.179.32:139 (Connection refused)
Error connecting to 63.251.179.32 (Connection refused)
14489: Connection to kingbee failed
I don't know why it is trying to resolve with 63.251.179.32 That is not one of the dns provided by my isp. I see that it is trying to resolve from my localhost too. I suppose that I may need to update my root dns file (can't recall the name of that file off hand), seeing as how it is the default file from the install of ETCH, from 2004 if memory serves. Help. What do I have to do to get this to work?
 
Old 01-09-2008, 02:45 PM   #2
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 921

Original Poster
Rep: Reputation: 46
More info:

I am unable to find this 63.251.179.32 address in any of the files for bind. So why is it using it?

I could understand if it was pulling an ip from db.root and not finding it because the listing in it is from 2004. But this ip is not in any of the db.(XXX) files. So where is it coming from?

It is not listed in the events(dropped/blocked) list in firestarter, so that doesn't seam to be the issue.

I suppose I can just purge bind and start over, but that is a pretty drastic step for a simple config issue.

Are the instructions in the how-to above for putting bind in 'jail' good? If they are not how would I undo them? Would purging bind take care of it?

Please help

I did get this when I tried to find out about this strange ip
Code:
~$ nslookup 63.251.179.32
Server:		166.102.165.11
Address:	166.102.165.11#53

** server can't find 32.179.251.63.in-addr.arpa.: NXDOMAIN
I can tell that it is trying to resolve a local name from a wan source. Don't know why it is doing that, or how to stop it. I would think I need some kind of data base that lists my local hosts to resolve from. I have not seen instructions for doing so in any of the how-to's I have looked at.

I have not changed any thing from the default setups in the local hosts on my network. Because the server and a local host are trying the use this same mystery ip I am assuming that this is something that originates in the server it's self.

I have only modified the file instructed to by the how-to.

Once again, please help. I don't know where to look.

Thanks
 
Old 01-09-2008, 05:15 PM   #3
KnightHawk
Member
 
Registered: Aug 2005
Posts: 128

Rep: Reputation: 15
First off I don't use debian, I use slackware so keep that in mind. I found the instructions you posted pretty crazy. Can't believe its that hard to get dns going in debian :/

Quote:
I am unable to find this 63.251.179.32 address in any of the files for bind. So why is it using it?
Check /etc/resolv.conf

I'm guessing your on DHCP, so the dhcp-client daemon will configure this file for you automatically, but you should be able to find that address there. This file tells your system where it should resolv DNS names.

I got this doing a reverse lookup on dig

Quote:
; <<>> DiG 9.4.1 <<>> -x 63.251.179.32
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 16894
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;32.179.251.63.in-addr.arpa. IN PTR

;; AUTHORITY SECTION:
179.251.63.in-addr.arpa. 10800 IN SOA ns1.pnap.net. hostmaster.pnap.ne t. 2007100400 28800 1800 604800 43200

;; Query time: 71 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Jan 9 15:01:45 2008
;; MSG SIZE rcvd: 103

root@gunstar:/temp1# dig -x 63.251.179.32

; <<>> DiG 9.4.1 <<>> -x 63.251.179.32
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 24032
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;32.179.251.63.in-addr.arpa. IN PTR

;; AUTHORITY SECTION:
179.251.63.in-addr.arpa. 10027 IN SOA ns1.pnap.net. hostmaster.pnap.net. 2007100400 28800 1800 604800 43200

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Jan 9 15:14:38 2008
;; MSG SIZE rcvd: 103
That resolves back to an ISP, yours I would assume. Although according to whois that address is not one of they're nameservers. Although it probably is. Perhaps your being forwarded or just round robin routed to other addresses. If its showing up in your resolv.conf and actually resolves addresses thats good enough for us.

Last edited by KnightHawk; 01-09-2008 at 05:18 PM.
 
Old 01-09-2008, 05:21 PM   #4
KnightHawk
Member
 
Registered: Aug 2005
Posts: 128

Rep: Reputation: 15
Quote:
I only want this dns to be a caching server and I haven't been able to find a suitable how-to for debian to accomplish this.
I don't have one either, and not sure if this helps your understanding, but bind 9 by default in most distros and even from source comes configured for caching-only service by default. Granted you still definately need a debian specific guide to make sure you make whatever neccessary configuration changes need to be made. It seems to me if you followed that link of yours, you have done that. So if we are now just talking bind in and of itself, meaning only its own configuration files, you can be secure in that its probably ready to go and just needs to be started.
 
Old 01-09-2008, 05:34 PM   #5
KnightHawk
Member
 
Registered: Aug 2005
Posts: 128

Rep: Reputation: 15
So heres what I think your missing in this. "/etc/resolv.conf"

Do this...

Start bind however it is you start bind.

Issue the following command to test it

"dig @your-nameserver-ip-here www.microsoft.com"

If it returns an answer and the SERVER: answer is listed as your dns servers IP, then its working as intended.

So the next step, is to force your clients, including your own dns server to use itself as a name server.

This happens via the /etc/resolv.conf file. This file typically has 3 lines, 1st line is the domain that you exist within. I'm guessing pnap.net here. The next 2 lines are usually domain name servers that you are resolving against. So what you will need to do, is add your own servers IP address in there and possibly remove the name server IP's for your ISP. Again keep in mind if your using dhcp assignment resolv.conf will be overwritten everytime you reboot or renew your address. There are ways to get around this, most simply a script that copies the real resolv.conf over the generated one. Or just setting for static IP.

So if you've done that, at this point from your console command line you should be able to ping www.microsoft.com and resolve and work.

At this point, you could do some extra credit work and configure your ISP's name servers as forwarders.. but thats for another discussion. Its typically bad form to use root servers unless your an ISP, and even then not so much. Not to mention probably faster as ISP nameservers are closer to you on the network.
 
Old 01-09-2008, 05:44 PM   #6
KnightHawk
Member
 
Registered: Aug 2005
Posts: 128

Rep: Reputation: 15
Quote:
Do I even need a domain name? I have read yes and no. So what is the truth for my setup? It would be nice to use a domain name because of the "cool" factor, but it's not that important.
No. And it will just complicate your life anyhow. Keep in mind too you can't just make up domains to use with your DNS server, it just won't work. If you must setup a working domain name setup, use "example.com" Thats the designated testing domain name that will only ever resolve back to the hosting machine assuming you've setup the zones correctly.

So short of getting your own domain, the other means would be to use your own ISP's domain and convince them to add your specific host name mappings to they're DNS. (not going to happen)

So really unless you want to do this, just to do it, stick with local host name mappings. And if you do want to do it, go ahead pay the 15 bucks for the year and buy your own domain name. I warn you now though, first time configuring zone files is a road that leads to mild insanity
 
Old 01-09-2008, 06:17 PM   #7
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 921

Original Poster
Rep: Reputation: 46
Thanks NightHawk

It is going to take me awhile to process the info you have kindly given. Yes, that whole zone thing was melting my brain.

Detailed post to follow

Once again Thanks
 
Old 01-09-2008, 06:59 PM   #8
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
One interjection from a DNS guy and a Debian guy, the default BIND9 install is a caching only server. You would need to modify /etc/bind/named.conf.local on the Debian install to become authoritative for any zones. If you haven't changed any of the config files, and BIND is running, then you are a caching server.

As to your problem, KnightHawk had the right answer. What was happening was when you ask BIND to resolve a short name (non-FQDN short for non-fully qualified domain name) it has a method to determine how it should look that name up. 99 times out of 100, the first line of /etc/resolv.conf is something like:

Code:
search (yourISP.com)
In my case, I have earthlink as my ISP, so unless I edit things, the first line of my /etc/resolv.conf is "search earthlink.net". When you use a non-FQDN, your resolv.conf file adds the non-FQDN to whatever the search line is. So when you ask for something like "kingbee" or "deciples", what actually gets asked for is likely to be kingbee.yourISP.com, or deciples.yourISP.com.

You need to stop using /etc/hosts if you are going to run DNS, you don't want 2 different processes driving the bus. Either ditch BIND and put all your machine in /etc/hosts, or commend out most of that file, and use DNS. But not both.

Peace,
JimBass
 
Old 01-09-2008, 08:28 PM   #9
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 921

Original Poster
Rep: Reputation: 46
Thanks NightHawk

That ip is NOT in /etc/resolv.conf I had already looked there. Hear it is:
Code:
nameserver 166.102.165.11
nameserver 166.102.165.13
nameserver 166.102.165.11	#kppp temp entry
nameserver 166.102.165.13	#kppp temp entry
I can surf the web just fine from all the machines connected to my network. So in that respect dns is working. The problem is that it is interfering with my ability to connect to samba shares from the command line with
Code:
$ smbclient -L (some host)
which produces the previously posted output. The strange thing is that smb4k, a kde samba file connection manager, sees the shares and will connect to them. So why is dns interfering with one and not the other?

My isp is Alltel and comming in via an evdo cell phone, so who knows about what name server I may be hitting. You may be correct in getting 'round robin'.

Quote:
you can be secure in that its probably ready to go and just needs to be started.
Watching the screen out put on boot I see that bind is being started, and as I recall the how-to has an instruction in it to restart bind after putting it in 'jail'.

At any rate "$ dig @166.102.165.11 www.alltel.com" results in
Code:
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1792
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 4

;; QUESTION SECTION:
;www.alltel.com.			IN	A

;; ANSWER SECTION:
www.alltel.com.		159	IN	A	198.133.104.148

;; AUTHORITY SECTION:
alltel.com.		57297	IN	NS	ns4.alltel.com.
alltel.com.		57297	IN	NS	ns2.alltel.com.
alltel.com.		57297	IN	NS	ns3.alltel.com.
alltel.com.		57297	IN	NS	ns5.alltel.com.

;; ADDITIONAL SECTION:
ns5.alltel.com.		64184	IN	A	198.133.105.168
ns2.alltel.com.		64184	IN	A	198.133.100.3
ns3.alltel.com.		64184	IN	A	198.133.100.4
ns4.alltel.com.		51086	IN	A	198.133.105.167

;; Query time: 172 msec
;; SERVER: 166.102.165.11#53(166.102.165.11)
;; WHEN: Wed Jan  9 19:41:28 2008
;; MSG SIZE  rcvd: 184


; <<>> DiG 9.3.4 <<>> @166.102.165.11 www.alltel.com echo
; (1 server found)
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42127
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;echo.				IN	A

;; ANSWER SECTION:
echo.			60	IN	A	63.251.179.32
echo.			60	IN	A	8.15.7.111

;; AUTHORITY SECTION:
echo.			65535	IN	NS	WSC2.JOMAX.NET.
echo.			65535	IN	NS	WSC1.JOMAX.NET.

;; Query time: 245 msec
;; SERVER: 166.102.165.11#53(166.102.165.11)
;; WHEN: Wed Jan  9 19:41:28 2008
;; MSG SIZE  rcvd: 110
So if I am understanding you corectly my resolv.conf should look like this based on the output above
Code:
WSC2.JOMAX.NET
nameserver 166.102.165.11
nameserver 166.102.165.13
Quote:
not sure if this helps your understanding, but bind 9 by default in most distros and even from source comes configured for caching-only service by default.
Yes, very much NightHawk. Now I am understanding where that ip came from. I did gather from the README.DEBIAN.?? (can't recall the exact name) that caching-only is the default setup. I don't think I have modified the defaults away from that.

Quote:
Again keep in mind if your using dhcp assignment resolv.conf will be overwritten everytime you reboot or renew your address. There are ways to get around this, most simply a script that copies the real resolv.conf over the generated one.
Is that what this script does?
Quote:
PPP Control Script:
-----------------

Unfortunately, 'ndc reload' will not honor any command line options that were
fed to named on the initial invocation. If you can live with that, and
want to wiggle your DNS configuration when your PPP link goes up or down, the
following script fragment from Francesco Potorti` <pot@gnu.org> may be helpful
to you:

I suggest adding this as bot /etc/ppp/ip-up.d/bind and
/etc/ppp/ip-down.d/bind:

================================================================
#!/bin/sh
if [ -x /usr/sbin/ndc -a -x /usr/sbin/named ]
then
/usr/sbin/ndc reload > /dev/null
fi
================================================================

This should cause no harm in any case, and should be helpful in these
cases:
- you configure bind as a forwarder. When ppp is down, it cannot access
the network. As soon as ppp is up, it is forced by the script to try
again, and it succeeds.
- someone writes a clever script that, coupled with the `usepeerdns'
command of pppd, makes a forwarding-only bind use the right servers by
rewriting the configuration file after ppp goes up. Then the script
above makes bind reload the configuration.

Now, someone should write that clever script :-)

By the way, this is a badly wanted feature, that should help setting up
a ppp connection automatically. Currently, setting up a ppp connection
is much easier on a windows system than on linux, and there is really no
reason why it should be so, given that all the tools are there.
It is in the README.Debian.gs or is it the other one they talk about? The one some clever person should write. I am not that clever or I would write it. Not yet at any rate.

Kind of funny; it was in the process of trying to get this script to the server that I discovered that I could not access my samba shares from the command line. As far as I know there is not an archiving tool on my server. Very minimal install. So I had opened it on the laptop via smb4k and saved a copy of the script in the share on the laptop. When I tried to open it on the server to put it where they say I discovered I could not access the samba shares.

Yes I have dhcp setup. It is needed for visitors with laptops so they can access www. It is on the same server as dns.

Quote:
configure your ISP's name servers as forwarders.
??? What do you mean ??? Simple quick explanation.

Quote:
"Do I need a domain name" No. And it will just complicate your life anyhow.
So how do I undo the steps I followed that told me to put in a domain name, (which I made up) and uncomplicate my life. My understanding was that it, the fictious domain name, would not be visible to the isp and so not cause problems. Not sure where I got that notion. I will try to track the the exact code I entered with the said name.

Thanks JimBass

You have helped to add to my confusion.
 
Old 01-09-2008, 09:00 PM   #10
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
I'm on my way out the door, so I have to keep this brief.

BIND is not interfering with your SAMBA at all. BIND is doing exactly what it is configured to do, which is to translate human-friendly domain names (yahoo.com, linuxquestions.org) into IP addresses. It doesn't even appear that you are using the BIND program you installed, unless your client machines are using the machine as their DNS. In any case, DNS cannot resolve a name like "MikesComputer." That is a non-FQDN, and BIND will only respond to FQDN names. The "search" line at the top of resolv.conf will turn non-FQDNs into FQDNs by adding the domain name in search to your short name request. Even if what you posted in /etc/resolv.conf is the full file (I don't believe it is), your ISP will still often add a domain name to any non-FQDN requests that they give.

In short, (and I'll explain more later, if you can post what it is that you don't understand or are having problems with,) you cannot use BIND to resolve "windows" networking names. The way to get something like that working is to run both BIND and DHCP on your server, so when the aforementioned "MikesComputer" makes a DHCP request, it gets an address, and BIND gets updated so that mikescomputer.yourdomain.com exists, which can then be queried using the non-FQDN mikescomputer, by adding "search yourdomain.com" to the beginning of your /etc/resolv.conf.

That being said, it doesn't seem that you have your head wrapped around the DNS structure enough to easily get a dynamic DNS server running. It isn't impossible, but it also isn't just a 1 or 2 step process.

Peace,
JimBass
 
Old 01-09-2008, 09:17 PM   #11
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 921

Original Poster
Rep: Reputation: 46
Thanks for the added confusion JimBass.

Quote:
You need to stop using /etc/hosts if you are going to run DNS, you don't want 2 different processes driving the bus. Either ditch BIND and put all your machine in /etc/hosts, or commend out most of that file, and use DNS. But not both
So how does dns resolve the names of the machines on my network? They are not visible to my isp, so they can't resolve the name. Only my server has an ip from them. I don't have my local machines listed in a file anywhere. I haven't gotten that far yet. And there is the whole dhcp thing that changes ip's occasionally to deal with.

Would NFS cause less problems, or just different ones? I could use that instead of samba, at least for the linux machines. Is there a NFS driver for windows? Not sure I like windows writing directly to a linux file system.

I do remember reading in a how-to some where the steps to take for this, but I have no idea where that how-to is.

Sorry I am such a slow learner.

Once again, Thanks for the help.
 
Old 01-09-2008, 09:54 PM   #12
KnightHawk
Member
 
Registered: Aug 2005
Posts: 128

Rep: Reputation: 15
Quote:
Originally Posted by rbees View Post
Thanks for the added confusion JimBass.



So how does dns resolve the names of the machines on my network? They are not visible to my isp, so they can't resolve the name. Only my server has an ip from them. I don't have my local machines listed in a file anywhere. I haven't gotten that far yet. And there is the whole dhcp thing that changes ip's occasionally to deal with.

Would NFS cause less problems, or just different ones? I could use that instead of samba, at least for the linux machines. Is there a NFS driver for windows? Not sure I like windows writing directly to a linux file system.

I do remember reading in a how-to some where the steps to take for this, but I have no idea where that how-to is.

Sorry I am such a slow learner.

Once again, Thanks for the help.

Quote:
So how does dns resolve the names of the machines on my network?
It doesn't unless you have a Fully Qualified Domain Name (FQDN). Such as mydomainname.org

Without that the only possible usefull configuration for you is caching-only name server. And that will only resolve other FQDN addresses.

NFS is by no means a solution. Once you list the host in the hosts file typing "smbclient -L deciples" will resolve. DNS (bind) is not involved with this.
 
Old 01-10-2008, 02:07 PM   #13
rbees
Member
 
Registered: Mar 2004
Location: northern michigan usa
Distribution: Debian Squeeze, Whezzy, Jessie
Posts: 921

Original Poster
Rep: Reputation: 46
Thank JimBass and NightHawk for your patients.

Quote:
BIND is not interfering with your SAMBA at all
If I am understanding and putting the pieces together correctly; some how the data base for my local machines does not exist or is not being accessed on my server. So when I
Code:
$ smbclient -L diciple
DNS is turning 'diciple' into a FQDN and then sending it on to the Alltel servers to resolve, which they can't do because they don't know about my machines, so they are returning an error.

So to solve this I need this machine list on my server. I have not made this list. According to JimBass, this is taken care of by my dhcp server, which seams to not be doing the job. So how do I track down why it's not?

From my second post
Quote:
I can tell that it is trying to resolve a local name from a wan source. Don't know why it is doing that, or how to stop it. I would think I need some kind of data base that lists my local hosts to resolve from.
I am tempted to uninstall bind9 and start again.

The changes I have made per the how-to, as I remember what I did where I didn't comment the files I changed. I have added some comments to the postings hear that are not in the files on the server. The first file I modified was /etc/network/interfaces

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.0.1 	# this line was added for dhcp
netmask 255.255.255.0 	# this line was added for dhcp
network 192.168.0.0 	# I added this line per the how-to
broadcast 192.168.0.255 # this line was added for dhcp
#gateway 192.168.0.1 	# I added this line per the how-to but had to comment it out for my network to work.
The 'gateway' line seams completely wrong for my setup because my internet comes in through my cell phone which is connected to usb. I am not sure of the purpose for putting the 'network' line in either. Everything worked fine without that line before the how-to. The ip's in the how-to are not the same as the ones hear.

The next file they told me to change was /etc/resolv.conf:
Code:
nameserver 166.102.165.11
nameserver 166.102.165.13
nameserver 166.102.165.11	#kppp temp entry
nameserver 166.102.165.13	#kppp temp entry
I did not make any changes to this file. It is as it was the first time I looked it it. But if I am understanding correctly it should look more like this.

Code:
search Alltel.com
nameserver 166.102.165.11 #primary
nameserver 166.102.165.13 #secondary
nameserver 192.168.0.1

The contents of /etc/hosts on the server:
Code:
127.0.0.1	localhost
127.0.1.1	Server.Bathive	Server # commented out per how-to and added the following
# line.  This line existed in the file when I first opened it.
#192.168.0.1 deciples.torah.org server  # changed it back because it didn't work when I 
# restarted the service.

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
I do see after pondering on this awhile that the line '127.0.1.1 Server.Bathive Server' is what my host name and workgroup names were before I put the domain name in as per the instructions in the how-to. My logic is telling me that if I undo that domain name thing it will solve my problem.

The ip 127.0.1.1 is confusing to me. That is not the static ip of my server nor is it the localhost ip, which is in the line above. Where did it come from?

These are the two commands that changed my host name into the domain.name
Code:
# echo deciples.torah.org > /etc/hostname
# /bin/hostname -F /etc/hostname
I think I understand the first one, it changed the entry in hostname form 'server.bathive to 'deciples.torah.org.

The second one escapes me though. Unless /bin/hostname is 'Fetching' the name from /etc/hostname and applying it to the system.

After I post this I am going to issue the above commands to change the host name back.

Once again thanks for helping me. Due to your patients and others like you I am just now getting to the place where I can begin to help other with less understanding than me. I pray that I can do the job as well as you have. Thanks.
 
Old 01-10-2008, 02:57 PM   #14
KnightHawk
Member
 
Registered: Aug 2005
Posts: 128

Rep: Reputation: 15
Quote:
So to solve this I need this machine list on my server. I have not made this list. According to JimBass, this is taken care of by my dhcp server, which seams to not be doing the job. So how do I track down why it's not?
I believe Jim is referring to a feature where DHCP will update your DNS server with whatever hostname it records for the host when it assigns an address. A neat feature, but for sake of argument don't take it into consideration.

You should be the one manually updating said list, which I think for you is gonna be the /etc/hosts file. With DNS only doing caching.
 
Old 01-10-2008, 03:08 PM   #15
KnightHawk
Member
 
Registered: Aug 2005
Posts: 128

Rep: Reputation: 15
Quote:
I think I understand the first one, it changed the entry in hostname form 'server.bathive to 'deciples.torah.org.

The second one escapes me though. Unless /bin/hostname is 'Fetching' the name from /etc/hostname and applying it to the system.
Correct!

/bin/hostname is only typically ran at startup, thus just changing the file wont' actually change your host name until you reboot, or run that command manually.


Quote:
The 'gateway' line seams completely wrong for my setup because my internet comes in through my cell phone which is connected to usb. I am not sure of the purpose for putting the 'network' line in either. Everything worked fine without that line before the how-to. The ip's in the how-to are not the same as the ones hear.
Gateway is in fact probably wrong as that IP is also being used as the interface address on the same machine. Your gateway should be the IP of the wireless USB interface or the machine that it lives on. Or to say it another way, the address of the next hop upstream from you.

Network specification helps define how your network is subnetted if at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DHCP or iptables interfering with VPN Skip-DMP Linux - Networking 1 04-18-2007 12:19 PM
HDD Error Interfering with FC5/6 Install Chris4 Fedora - Installation 1 02-04-2007 03:07 PM
xine is interfering with real player Paxmaster Linux - Software 0 01-05-2005 05:59 PM
Geforce FX 5200 interfering with WMP54GS? andydicktwin Linux - Hardware 1 12-31-2004 11:47 AM
Is SSL Interfering with Samba? shassouneh Linux - Networking 1 11-28-2003 03:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration