-   Linux - Server (
-   -   BCC mappings are not working in postfix (

dhiman.manish23 10-08-2011 02:00 AM

BCC mappings are not working in postfix
Dear All,

I have a postfix mail server hosted in my office. My mail server is working fine and all bcc mappings are also working fine. But, I am trying to map bcc mapping of one user to multiple users in postfix.
My sender_bcc and recipient_bcc look like this

Code:      ,
It means I want to forward a copy of every mail sent or received by to and

But the problem is only is receiving a bcc copy. In mailwatch or mailscanner it shows that a bcc copy of mail is also forwarded to, but in actually that forwarded copy is not received at

I am not getting where the problem is.

Your suggestions or ideas will help me a lot.

Thanks and Regards
Manish Dhiman

lithos 10-09-2011 01:10 PM

try looking at
- here
- here

if it will help you

I don't know what the exact setting will do.

dhiman.manish23 10-10-2011 09:22 AM

Dear lithos, thanks for replying but the problem is still not solved.

Ian John Locke II 10-10-2011 10:21 AM

Did you try removing the space between the comma and the second email address?

dhiman.manish23 10-11-2011 01:26 AM

Problem is still same even after removing the space after comma. one thing more I get to know is that if I add bcc mapping to only 1 email address then its working fine but if I put bcc mapping to 2 or more email address by putting comma or space between the email addresses, the bcc mapping doesnt work for any of the email ids.

dhiman.manish23 10-11-2011 02:01 AM

for example
if i do

it works fine
but if i do


none of the admin accounts received any bcc copy of any mail send or receive by abc user.

lithos 10-11-2011 05:20 AM

maybe here is something you need to do
under "Problem Fixed, ..."
or here the basic solution

dhiman.manish23 10-13-2011 01:12 AM

The problem is not solved yet.

satishchahar 07-28-2012 05:51 AM

I am also looking for an answer to the same query. Did anyone get workaround on this?

All times are GMT -5. The time now is 12:13 AM.