Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 09-09-2009, 05:58 AM   #1
LQ Newbie
Registered: Sep 2009
Location: Here and there
Distribution: Centos - Fedora - RHEL
Posts: 4

Rep: Reputation: 0
Autofs/Automount configuration problems

Hello all,

I'm preparing for my RHCE exam and doing a few experiments with my Linux servers in the lab, as the title stated I'm facing a few problems making this to work.

I've grasped, well more or less :P, the logic behind autofs and its configuration files but yet it seems I can't make it work as expected. I've checked the Red Hat deployment guide, a few blogs and guides for other distros but yet without success.

I've tried it both with CD and NFS shares, but it seems even if autofs reads the configuration files I create yet it does not automatically mount the directory (nfs or cd) and in the log files the only error I can see is related to the system that can't find the NIS+

Anyone can suggest me the right direction? Or am I simply doing something wrong?

Thanks C.
Old 09-10-2009, 12:51 AM   #2
LQ Guru
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,406

Rep: Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396Reputation: 2396
Show us the cfgs for a start. Also, if it's 'not working' there will/should be an error msg somewhere eg /var/log/messages.
Old 09-11-2009, 02:21 AM   #3
LQ Newbie
Registered: Sep 2009
Location: Here and there
Distribution: Centos - Fedora - RHEL
Posts: 4

Original Poster
Rep: Reputation: 0
Hi Chris, thanks for your reply. Last night while trying to troubleshoot this it seems I've managed to make autofs work, even if I'm still not sure where the problem was.

I'll try to post the conf file as soon as I have access to lab again to see if there is something wrong there, just a quick question/doubt how can I control where the remote directory is mounted on the local FS?

For what I've understood and read in the Deployment Guide I should use soemthign like this :

<mount point> <options if any> <location of the remote dir>

This is what I've done in my auto.master so that the NFS share should have mounted under /example directory on my FS, which exists, but the directory was actually mounted under /net directory.

Did I misunderstand something and this is a normal behaviour or I am simply doing something wrong?
Anyhow I'll post the conf file asap so maybe I can finally understand this.

Thanks and sorry if my questions seems silly but in my experience I never used autofs, our systems are mainly based on Windows so I have some samba servers and the clients map via normal windows smb.

Thanks, C.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Automount Netapp NFS shares on Linux with AUTOFS athreyavc Linux - Server 2 10-30-2007 05:34 PM
SELinux Message when trying automount/autofs louisb Linux - Security 1 07-28-2007 04:27 AM
Autofs and automount socks Linux - Software 0 07-20-2004 12:28 PM
samba & autofs (automount) acb67 Linux - Networking 4 06-10-2004 10:57 AM
Setting up automount with autofs smattbac Slackware 0 10-12-2003 08:51 AM > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 11:36 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration