Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 12-31-2008, 06:44 AM   #1
LQ Newbie
Registered: Oct 2006
Location: Brighton, UK
Posts: 18

Rep: Reputation: 0
Applying the Linux CIFS Client IPv6 Name Resolution Patch

A patch is available to enable IPv6 name resolution when mounting a share:

However I'm not sure what this patch should be applied to! What source do I need?

I have posted a comment on the original blog page but thought that someone might have already applied this patch.

Old 12-31-2008, 01:30 PM   #2
LQ Newbie
Registered: Dec 2008
Distribution: Debian
Posts: 8

Rep: Reputation: 0
Are you sure that patch hasn't already been applied to the latest kernels? You can try changing your entire system to try and use ipv6 address first by adding 'options inet6' to your /etc/resolv.conf. Becareful with this though, I've seen it break some perl apps that aren't ipv6 friendly.
Old 01-01-2009, 10:14 AM   #3
LQ Newbie
Registered: Oct 2006
Location: Brighton, UK
Posts: 18

Original Poster
Rep: Reputation: 0
After a couple of other quick tests it looks like it's not just name resolution that is the problem - I can't use the IPv6 address in /etc/fstab either.

If I use //<ipv6_address>/data as the server & share, I get this:

# mount -v /mnt/fs01data/
parsing options: rw,credentials=/home/jim/.smb
mount error: could not find target server. TCP name <ipv6_address>/data not found
No ip address specified and hostname not found

I get the same error trying to use <hostname>/data.

If I add options inet6 to /etc/resolv.conf the error doesn't change when using the ipv6 address as the servername.

Bizarrely though, if I change back to using the hostname it thinks it has resolved it to another ipv4 address:

# mount -v /mnt/fs01data/
parsing options: rw,credentials=/home/jim/.smb

mount.cifs kernel mount options unc=//<hostname>\data,ip=,user=user,pass=pass,ver=1,rw,credentials=/home/jim/.smb

I'm not sure where it is getting this IP from, as it isn't anything to do with me:

OrgName: AT&T Global Network Services
Address: 3200 Lake Emma Road
City: Lake Mary
StateProv: FL
PostalCode: 32746
Country: US

My kernel version: 2.6.27-9-server

I am able to resolve the IPv6 address for the server using dig, ping it successfully, etc.

So it looks as though patching might still be required? I have found another link with the same patch that has some more information:

"The current name resolution scheme in mount.cifs is IPv4 only. Expand
it to be protocol-independent. Also take advantage of the fact that
getaddrinfo() returns a list of addresses and have mount.cifs try each
in turn until it hits one that's reachable and allows the socket to


cifs, ipv6, mount

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Applying samba patch kool_kid Linux - Networking 2 12-14-2007 08:37 AM
Applying patch from CD-ROM M K Mandriva 1 01-26-2006 02:26 PM
applying kernel patch pirozzi Debian 1 12-01-2004 08:47 AM
applying patch? alaios Linux - General 1 11-29-2004 11:41 AM
applying a patch darthczyz Linux - Newbie 2 05-07-2004 09:44 AM > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 01:21 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration