-   Linux - Server (
-   -   Apache Module Load Error (

vishallagdev 09-09-2006 12:26 AM

Apache Module Load Error
Hi Guys,
I recently installed Fedora 5 (.2174) and wanted to setup webserver with it. I did some settings using the GUI of httpd i.e, system-config-httpd. When I tried to start httpd from the terminal I got this error.

Apache Version 2

[root@localhost ~]# httpd
httpd: Syntax error on line 194 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/ into server: /etc/httpd/modules/ undefined symbol: array_free

So I deleted the line 194 from the httpd.conf file and restarted httpd

[root@localhost ~]# httpd
httpd: Syntax error on line 195 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/ into server: /etc/httpd/modules/ undefined symbol: int2hex

Again I deleted the 195th line so see this

[root@localhost ~]# httpd
httpd: Syntax error on line 196 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/ into server: /etc/httpd/modules/ cannot open shared object file: No such file or directory

I went on deleting the line with error till I was sick of doing this ..... and finally found this forum.....
Please help me.....

sysconfig 09-09-2006 02:53 AM

If you dont want this module then you need to remove or uncomment related parameter in httpd.conf file. Generally you many need to uncomment the tags between <..> .... </..>


wdlewis 12-02-2006 12:11 AM

If you did anything like I did you probably thought that the System/Administration/Server Settings/HTTP GUI would give you a good httpd.conf file. Wrong! I was browsing through the GUI changed a setting and set it back and when I exited the GUI I answered yes to overwriting the config file. I was lucky that the GUI had made a .bak file I renamed it and overwrote the httpd.conf file made by the GUI.

Micro420 02-02-2008 11:20 PM

Yes, I also am noticing that the GUI www editor, system-config-httpd, cannot properly produce a workable httpd.conf file. I am getting the exact same errors about it not being able to find the proper modules. It is quicker and easier to do it by hand than relying on system-config-httpd.

I tried it on CentOS 5.1, by the way. You would figure they could fix it by now, but apparently not!

baldur_the_god 02-02-2008 11:45 PM

the best way to configure apache is by command line. the gui does not work...everytime you use it, if there is something the gui has not been configured to know, it deletes it leading to cascading failures like you are doing. i would highly suggest that if you want to configure any .conf files, you do it yourself...not to rip linux...i love the penguin that roars...

the failure may have started however, but before you start anything you should go to the directory you are about to work in and

cp file file.back

so you have a back-up if anything happens. the gui did probably not recognize your system correctly and when it rewrote, failed the entire thing.

after you have wrote by command line, use

apachectl configtest

to check how you have done and then you do not have to worry about cascading failures like you are facing...and if you have a back-up you can just revert to that if you did mess things up...


All times are GMT -5. The time now is 10:55 PM.