-   Linux - Server (
-   -   All connections being refused on LAN server (

Carpintonto 05-26-2010 08:10 AM

All connections being refused on LAN server
I have a little file server, which also acts as a printer server and it has a web server implementation for Mapserver too.

Suddenly, nothing can connect.

if I try ssh

john@john-desktop ~ $ ssh -vv
OpenSSH_5.1p1 Debian-5ubuntu1, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /home/john/.ssh/identity type -1
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug2: key_type_from_name: unknown key type '-----END'
debug1: identity file /home/john/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file /home/john/.ssh/id_dsa type -1
ssh_exchange_identification: Connection closed by remote host

or ftp

Looking up
Connected to
Disconnecting from site


Firefox can't establish a connection to the server at

Firefox can't establish a connection to the server at
The little server had been running Debian Etch headless (no gui, no monitor, no keyboard) for a couple years just fine. Suddenly all connections are refused, from both Linux boxes (LinuxMint Gloria)

I am not running any software firewalls on any of the boxes, nor have I messed with anything on our router (Linksys Wireless-G)

Also, all connections are ethernet, not wireless, and the server and the other two boxes are assigned IPs - no dhcp issue
thanks for looking -

michaelk 05-26-2010 08:31 AM

Can you ping the server?
can you still access files and print?

Carpintonto 05-26-2010 08:34 AM


Originally Posted by michaelk (Post 3981697)
Can you ping the server?
can you still access files and print?

I can ping, but not print. Being unable to print is how I discovered the problem.

tredegar 05-26-2010 10:52 AM

It's a "little" file server, and it has been running for a couple of years (gotta love linux!).
Maybe the logs have filled up your diskspace? So now there's no room to run anything?

Root should have 5% of diskspace reserved, so if you can login as root, maybe you can fix things. Root logins by ssh are usually disabled by default though.

Can you attach a keyboard and monitor to it, and then login as root?

Carpintonto 05-26-2010 11:08 AM

@ tredegar -

thanks - that was my suspicion too, and that is what I will try next. I recall I had less than 10% space left the last time I looked and my cups error log was saying something about "too big." I did try logging in as root via ssh - no go. I'll report back after I attempt to log in as root with a keyboard and monitor attached.

tredegar 05-26-2010 01:33 PM


Please let us know how you get on.

Carpintonto 05-26-2010 03:01 PM

On boot up, fsck died with exit status 4
Went to maintenance shell when prompted for root password and ran fsck.
fsck reported

File /var/log/samba/cores/smbd/core ... has multiply claimed block(s) shared with one file(s)
I went with default for all the prompts and rebooted when fsck finish.

When I try to log in as root, I always get this error message

/bin/login: error while loading shared libraries: /lib/ ELF file data encoding not little-endian
Ok now - I tried rebooting to single user mode and got stuck again, then let it reboot again and fsck ran again on it's own and fixed some more stuff, and I was in as root. Opened another virtual console (Left-Alt -F2) and logged in as me, then tried ssh from one of the linux boxes as yet another user - all good, and I have a little over 5 GB free space so there's room to move. I think my object lesson for today is rtfm for fsck.

tredegar 05-26-2010 04:54 PM

Thanks for the follow-up.

fsck is not happy. So the filesystem isn't able to function properly. That's possibly why you are getting obscure messages like "/bin/login: error while loading shared libraries:..."

Could be that your server has died, for reasons, at present, unknown.

You can perhaps boot your server from a live CD mount its filesystem, and rescue personal files you need to an external HDD. I suggest you try this now if your personal files are important.

Then maybe a reinstall, or functioning hardware on your server, is required.

You will have to do some diagnosing.

All times are GMT -5. The time now is 09:09 PM.