LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Alias on Apache to home dir on Fedora 8 throws Forbidden! (https://www.linuxquestions.org/questions/linux-server-73/alias-on-apache-to-home-dir-on-fedora-8-throws-forbidden-628950/)

vigilnt 03-18-2008 10:39 AM

Alias on Apache to home dir on Fedora 8 throws Forbidden!
 
Hi everyone! I really need some help!

Before running Fedora 8 I was using Ubuntu 7.10 and I had LAMP installed.
I am working on two PHP projects of mine, and I made two Alias on apache.conf to redirect from /var/www/url? to /home/username/url? , where url? stands for the directory of my projects.
On Ubuntu this was working fine, I simply added that 2 lines to my apache.conf ("Alias /url /home/username/url") and when I entered "localhost/url" on my browser it showed my page!

Well, this weekend I decided to try Fedora 8, I set up the Lamp server, and everything was working fine, until I tried to make the same Alias I had on Ubuntu... Now the browser just throws forbidden at me. This is what I already tried to do:
  • I set the Alias on the "/etc/httpd/conf.d/alias.conf" file, like this:
    Code:

    Alias /fontes "/home/vigilnt/workspace/fontes/public"

    <Directory "/home/vigilnt/workspace/fontes/public">
            Options Indexes FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
    </Directory>

  • I set the same thing on the "/etc/httpd/conf/httpd.conf" file
  • I changed the permissions of the public directories on my home to 777
  • I disabled SELinux
  • I tracked "/var/log/httpd/error_log" and this is what it says:
    Code:

    [Tue Mar 18 15:19:24 2008] [error] [client 127.0.0.1] (13)Permission denied: access to /fontes/ denied

This LAMP server is only for developing, I don't need to connect to it from any other machine, i really need some help!

Anyone?

Thanks

PS: I wanted to write this thread on the server section, and did it on the security one... If someone could change it I would appreciate. Thanks.

merize147 03-18-2008 08:16 PM

what about the permissions on the home and user folder? The apache user will need execute permissions on these folders to get to the public folder?

vigilnt 03-19-2008 08:52 AM

I've already solved this problem with some help from the fedoraforums.

It was a permissions issue. I had to add my user to a new group as well as apache.

Thanks anyway.


All times are GMT -5. The time now is 08:38 PM.