LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 11-15-2010, 01:25 PM   #46
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042

I cannot think of something that has changed between Slackware 12.0 and 13.1, that is responsible for this behavior, except maybe iptables.
But as you said, even with blank iptables, you can't connect to the webserver.
Can you ftp to your server now? Because ftp is more tricky that http, as you have to open 2 port on the firewall!
 
Old 11-17-2010, 08:16 AM   #47
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
I will make some tests here install slackware12 and 13.1 and analyze it I will leave the thread open for some days (till I end the tests) and I will return the results.

Thanks Mr(s).
 
Old 11-19-2010, 01:35 PM   #48
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
Every time when I boot my computer I have to type ifconfig eth0 0.0.0.0 and after pppoe-start, I was thinking about it, it could be a problem ?

Apache works on Debian, Slackware 12, Windows and OpenSUSE but on slackware 13.1 no.
The unique diference is what I said about ifconfig. All configurations was the default for setup apache.


Thanks
 
Old 11-19-2010, 03:45 PM   #49
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
Could be. When apache starts is binds on port 80 on every available interface (assuming that you use the "Listen 80" directive).
After running ifconfig and pppoe-start you get a new interface and a different IP address for eth0.
So stop/start apache to make it bind again on port 80 of the new interfaces.
 
Old 11-20-2010, 12:18 PM   #50
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
I have ever started apache after to connect.
 
Old 11-20-2010, 04:03 PM   #51
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
Hi,

Please confirm if the following procedure is correct and what you get each time:

1. Slackware boots and as root you have to run:
Code:
ifconfig eth0 0.0.0.0
pppoe-start
Whats gives:
Code:
ifconfig -a
iptables -L
2. You stop and the start apache.
Code:
/etc/rc.d/rc.httpd stop
/etc/rc.d/rc.httpd start
Whats is the output of:
Code:
netstat -tanpl|grep httpd
BTW, do you really need to run that ifconfig command at startup? I've never used a ppoe connection, but looking here at LQ I've found this thread about ppoe. Take a look at eth0 settings, because I think your initial ifconfig command is wrong and it's responsible for this situation.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot Access Apache Web URLs Remotely eliassal Linux - Server 4 06-08-2010 09:31 AM
Cannot Access Apache Web URLs Remotely Without Port Number nikhil010586 Linux - Server 8 03-07-2009 04:27 AM
Help - Setting up Apache/CGI/Perl remotely - Redhat/Putty shallowfellow Linux - Server 1 12-13-2007 03:36 PM
Can't access Apache remotely zwyrbla Linux - Software 7 03-23-2005 07:14 PM
Editing webpages on Apache remotely patpawlowski Linux - Software 2 02-07-2004 12:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration