LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 11-13-2010, 05:59 AM   #31
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2

Are you sure that your box gets the same IP in Slackware as in Windows?

I get my IP by DHCP from the pppoe provider the the IP changes each connection but it was not a problem on windows.
 
Old 11-13-2010, 07:17 AM   #32
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
Can I ask how you are using eth0? If I understand you correctly, ppp0 is your connection to the INternet, and your ifconfig output shows that eth0 is using IPv6 while ppp0 is using IPv4. If my understanding of how LISTEN works is right, Apache should be listening to all interfaces the way you have it set up, however, it might be worth forcing it to listing to the ppp0 IP address to see if somehow it is getting confused. So if you replace Listen 80 with Listen 189.18.214.20:80 in your httpd.conf and restart Apache (only use whatever IP address you got from your ISP) it might work.
 
Old 11-13-2010, 08:52 AM   #33
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
This makes things more complicated. I was under the impression that your box is behind a modem/router and you are doing the forwarding in that router. From ifconfig it's your box that is doing the router also.
So, you have to forward ipv4 packets from ppp0 to eth0 (ipv6).

If you don't need ipv6 for some specific reason, blacklist the ipv6 module and give your box a fixed ipv4 IP.
Also run:
Code:
echo 1 > /proc/sys/net/ipv4/ip_forward
to enable ip forwarding from ppp0 to eth0, flush iptables (see post #27) and test.

Or better, use this script to create a set of rules and the forwarding needed for your box.

Regards
 
Old 11-14-2010, 07:53 AM   #34
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
I do not use ipv6 I get ride of it in firefox, someone can ping me, someone can talk with me on skype, someone can send a mail to me and I receive it on Thunderbird but nobody can access my pages on the apache server! @!#$@#$@#@@@!#@!#
I cleared iptables, I tried change my httpd.conf (listen IPADRESS:80) I tried to change the port (80, 8080, 7777, 6372, 8000), my router have the firewall disabled any traffic can pass through it. I really do not know what to do I'm thinking about format it and return to my slackware 12 (but I do not want to do it).
 
Old 11-14-2010, 08:34 AM   #35
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
IF you don't use ipv6, then what is this?
Quote:
eth0 Link encap:Ethernet HWaddr >>My HW ADD here<<
inet6 addr: >>My INET ADDR Here<<< Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:790 errors:0 dropped:0 overruns:0 frame:0
TX packets:865 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:405491 (395.9 KiB) TX bytes:121543 (118.6 KiB)
Interrupt:23 Base address:0xe000
Apache needs just a "Listen 80" to listen on all interfaces on port 80. If it finds a ipv6 interface it will listen on that.

If you don't want to go back to Slack-12, do as I've already told you:
Blacklist the ipv6 module
Use netconfig (or whatever way you prefer) to assign an ipv4 address to eth0
Since you can't find the script that initializes iptables, flush'em. Or better use the quicktables script (the link in my previous post) to setup iptables, NAT and port forwarding
 
Old 11-14-2010, 09:51 AM   #36
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
when I said "I do not use" I mean that I do not use it or I do not need it, or it not is desired. I will try it now.
sorry if i'm beig rude.
 
Old 11-14-2010, 11:11 AM   #37
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
I blacklisted ipv6, and apened 80 on iptables and when I start apache it works (but no remotely), but my ifconfig changes and netstats returns:
bash-4.1# netstat -tanpl|grep httpd
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 5147/httpd
and my ifconfig:
Code:
bash-4.1# ifconfig
eth0      Link encap:Ethernet  >>HWaddr HWADDR<<  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24106 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39255 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7472958 (7.1 MiB)  TX bytes:6414511 (6.1 MiB)
          Interrupt:23 Base address:0x8000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:355 errors:0 dropped:0 overruns:0 frame:0
          TX packets:355 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:200622 (195.9 KiB)  TX bytes:200622 (195.9 KiB)

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:201.26.21.205  P-t-P:200.204.210.226  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:23868 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39045 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:6932515 (6.6 MiB)  TX bytes:5548417 (5.2 MiB)
But the problem remains.
 
Old 11-14-2010, 11:52 AM   #38
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
So now:

1. apache listens on all available ipv4 interfaces.
2. You haven't assign an IP address in eth0. Use netconfig, or if your box is standalone, use temporarily:
Code:
ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up
3. What is your iptables rules? Flush them and see if you can access apache remotely
 
Old 11-14-2010, 12:21 PM   #39
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
I assignbed the ip adress to eth0, and flushed iptables not was changed.
My iptables remain the same, I flush it or add 80 port on it when I try to up the server ipv6 is blacklisted it make my internet faster too.
I'm losing alternatives.
 
Old 11-14-2010, 01:06 PM   #40
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
Huh, strange?
Does apache on windows listens on port 80? Or you're using some other higher port?
If you didn't say that apache is accessible when you run it on windows, I would suspect that your ISP is blocking port 80.

Another thing to try, is to change the Listen directive to:
Code:
Listen 1080
and see if you can access it, using http://x.x.x.x:1080 (where x.x.x.x is your public IP)
 
Old 11-14-2010, 03:06 PM   #41
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
Now my modem/router magicaly changes itself and blocked my ftp (it was clear and never happened nothing with it), yes on windows is 80 port and works pretty well, I reseted the modem/router and configured it right again but nothing happens. I'm crazing! I think my neighboor want to kill me because everyday I call him for test ahshsahsahsahsahsah.

Thanks

Last edited by Willian; 11-14-2010 at 03:07 PM.
 
Old 11-15-2010, 12:48 AM   #42
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
H,
Quote:
Now my modem/router magicaly changes itself and blocked my ftp (it was clear and never happened nothing with it), yes on windows is 80 port and works pretty well, I reseted the modem/router and configured it right again but nothing happens.
Is it a modem, or a modem/router? Since you have a ppp0 interface on your linux box I guess it's just a modem.
Using this configuration you were able to ftp in your box from the internet?
 
Old 11-15-2010, 07:46 AM   #43
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
yes I can use ftp, but not http, is modem but can works like a router too.
 
Old 11-15-2010, 08:43 AM   #44
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,175
Blog Entries: 1

Rep: Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042Reputation: 2042
Hi,

Since you can ftp into your linux box, why don't you do the same setup for http in modem/router/firewall (whatever is between you and the internet)?
 
Old 11-15-2010, 11:06 AM   #45
Willian
Member
 
Registered: Oct 2010
Location: Earth
Distribution: Slackware64
Posts: 38

Original Poster
Rep: Reputation: 2
Is the same configuration in the windows and slackware12 it works, it only happen on slackware13.1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot Access Apache Web URLs Remotely eliassal Linux - Server 4 06-08-2010 09:31 AM
Cannot Access Apache Web URLs Remotely Without Port Number nikhil010586 Linux - Server 8 03-07-2009 04:27 AM
Help - Setting up Apache/CGI/Perl remotely - Redhat/Putty shallowfellow Linux - Server 1 12-13-2007 03:36 PM
Can't access Apache remotely zwyrbla Linux - Software 7 03-23-2005 07:14 PM
Editing webpages on Apache remotely patpawlowski Linux - Software 2 02-07-2004 12:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration