LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 07-21-2017, 01:38 AM   #1
red888
LQ Newbie
 
Registered: Jan 2013
Posts: 6

Rep: Reputation: Disabled
“cobbler buildiso” not working


centos 7

I installed cobbler Edited the settings file to listen on the cobbler servers own IP address Ran "cobbler buildiso" Then took that iso and tried to boot a VM from it but it won't work

When I look at whats on the ISO there is a "images" folder an "isolinux" folder and a "TRANS.TBL" file. The images folder is empty (do I need to run a cobbler command to create an image?)

When setting could be causing this failure to boot? its like its not even loading any OS or anything, it just fails immediately
 
Old 07-21-2017, 03:37 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,470

Rep: Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770
I'll guess on this.

Not sure what you have. See this to start. https://cobbler.github.io/manuals/2....Build_ISO.html

As you can see the normal method is to use this for pxe booting and I assume while it has access to cobbler server. The end of that page has way to make a more inclusive iso.
 
Old 07-23-2017, 02:21 PM   #3
red888
LQ Newbie
 
Registered: Jan 2013
Posts: 6

Original Poster
Rep: Reputation: Disabled
It has network access to the cobbler server, but I think its generating a broken iso. Should the images folder not be empty?
 
Old 07-23-2017, 03:01 PM   #4
red888
LQ Newbie
 
Registered: Jan 2013
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hey thanks for getting back to me! so I at least know whats happening now- I need UEFI boot.

I booted the iso from a system that did not require UEFI and it worked. Im using Hyper v and gen1 VMs boot the iso but gen2 (requiring efi) do not.

So now my question is if there is a switch or config to get cobbler to build an EFI bootable iso.

Im working with the official centos 7 minimal ISO which I imported to cobbler. I can boot from the official ISO no problem so I know it has EFI loaders on it that work.

--edit: Have to confess my ignorance here, I don't even know what the images folder is for or why that folder has stuff in it on the official iso but not on the one cobbler generated- or even if I should care?

Last edited by red888; 07-23-2017 at 03:02 PM.
 
Old 07-23-2017, 03:17 PM   #5
red888
LQ Newbie
 
Registered: Jan 2013
Posts: 6

Original Poster
Rep: Reputation: Disabled
Ok so I think I have a way of doing this, but I don't have enough knowledge of what the actual param would be

Looks like cobbler is running this command to make the iso:
Code:
mkisofs -o /var/www/cobbler//pub/generated.iso  -r -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -V Cobbler\ Install -R -J -T /var/cache/cobbler/buildiso
The buildiso command has this switch:
Code:
 --mkisofs-opts=MKISOFS_OPTS
                        (OPTIONAL) extra options for mkisofs
So would using the --mkisofs-opts= switch with the right arguments yield a iso with UEFI boot support?
 
Old 07-23-2017, 07:31 PM   #6
jefro
Moderator
 
Registered: Mar 2008
Posts: 18,470

Rep: Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770Reputation: 2770
I doubt cobbler can make a uefi bootable media from an image that isn't. There aren't a lot of changes between them but it isn't a common task.

The link I posted had no info on options for conversion.


This is one example of a way to convert. https://askubuntu.com/questions/5094...ut-boot-repair

Another. https://help.ubuntu.com/community/UE...or_Legacy_mode

Last edited by jefro; 07-23-2017 at 07:32 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cobbler get-loaders MilanZambre Linux - Newbie 0 04-18-2015 07:45 PM
Cobbler Assistance tgaler1 Linux - Software 0 09-13-2012 12:05 PM
[SOLVED] cobbler configuration | wrong /cobbler/tftpboot/pxelinux.cfg/ newbie0101 Linux - Server 2 05-21-2012 07:42 AM
Cobbler+RIS joeldavis Linux - Server 0 11-17-2011 01:00 AM
cobbler error angle2009 Linux - Server 5 01-09-2010 04:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration