-   Linux - Security (
-   -   xinetd, remote X display, hosts.allow (

fgeter 01-12-2003 11:45 PM

xinetd, remote X display, hosts.allow
I have two computers, one fast (the remote) and one slow (local) on a
nated network behind a router. I am using Mandrake 9.0. I have set
up the remote machine to allow remote X sessions. I am successful in
getting it to run on the local machine so that the X display is on the
local machine but I am actually working on the remote fast machine.

I would like to tunnel the local X session through a SSH tunnel (not just an X app butthe whole display) to the fast machine. In setting this up I discovered
that even though I set my hosts.allow on the remote machine to only say:

sshd: slowmachinehostname : ALLOW

and my hosts.deny to:


It would still allow my slow local machine to connect in the raw to the remote machine. Mandrake uses xinetd and it does utilize the hosts.allow and hosts.deny. The local machine cannot telnet to the remote machine with the above configeration.

Two questions:
1. How do I get my remote machine to not allow X traffice in the raw.
2. How do I can get the X display to tunnel through SSH.


All times are GMT -5. The time now is 11:22 PM.