LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices


Reply
  Search this Thread
Old 07-08-2019, 10:10 AM   #1
fussel55
LQ Newbie
 
Registered: Feb 2016
Location: Kiel, Germany
Distribution: openSUSE, Debian, Raspbian
Posts: 2

Rep: Reputation: Disabled
Angry Why crash certbot-auto after creating virtual environment ?


Hi friends,
up to now certbot-auto goes well.
But today Certbot has problem setting up the virtual environment.
Reason:"We were not be able to guess the right solution from your pip
output. Had a problem while installing Python packages.
THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them."

I didn't find anything help on
https://certbot.eff.org/docs/install...al-environment

I don't know how to update the hashes on my Debian Stretch on Raspberrypi Version 3b.

Who can help me?
 
Old 07-09-2019, 12:33 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,564

Rep: Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794Reputation: 1794
Quote:
Originally Posted by fussel55 View Post
Hi friends,
up to now certbot-auto goes well.
But today Certbot has problem setting up the virtual environment.
Reason:"We were not be able to guess the right solution from your pip
output. Had a problem while installing Python packages.
THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them."

I didn't find anything help on
https://certbot.eff.org/docs/install...al-environment

I don't know how to update the hashes on my Debian Stretch on Raspberrypi Version 3b.

Who can help me?
Read this thread and try the patch proposed.

Refards
 
  


Reply

Tags
debian stretch, raspberry pi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Secure your webserver with improved Certbot LXer Syndicated Linux News 0 05-26-2017 10:01 AM
[SOLVED] Bundle SSL certificates with LetsEncrypt/Certbot? kikinovak Slackware 1 03-14-2017 07:58 AM
LXer: Using certbot to secure your personal site LXer Syndicated Linux News 0 02-23-2017 02:01 PM
crash () { crash|crash& }; crash grob115 Linux - Security 6 05-07-2011 03:06 AM
Crash, Crash, Crash, Crash and You Guessed it Crash! little_penguin SUSE / openSUSE 8 07-04-2005 09:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 07:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration