-   Linux - Security (
-   -   why can't i generate a new certificate with openssl? (

achouramira 04-13-2005 06:33 AM

why can't i generate a new certificate with openssl?
i've been working on generating certificates with openssl, i've generated a ca certificate, a private key as well as a request, but when i type the command to generate a user certificate i got this error message:
"using configuration from openssl.cnf
wrong number of fields on line 1( looking for fields 6, get 1, ' ' lefts) "
the line 1 mentioned here, as i understood, is the line 1 of the openssl.cnf and it contains a comment !!!
the problem is that i have already worked with this same configuration file and it worked successfully, and i'm sure that i haven't made any modification on it.

thanks ,

lars08154711 04-28-2005 08:15 AM

I got this error recently, because I deleted the last line in the Index.txt file but I did not delete the newline character.
Try editing the file and delete all newlines (lf) in it.

All times are GMT -5. The time now is 03:20 AM.