-   Linux - Security (
-   -   VNC and iptables in FC4 (

hazmatt20 07-06-2006 08:46 AM

VNC and iptables in FC4
So, after disappointed attempt at FC5 (32 bit wouldn't boot up for me, and 64 bit had too many problems. Plus no flash. No homestar? No OS), I reinstalled FC4. Almost back to normal except with VNC. This shouldn't be too difficult b/c it connects correctly if iptables is stopped, so the problem is in iptables. Gasp. I've tried a few things with no success. What do I need to do?

Fadoksi 07-06-2006 11:00 AM

You must open the ports from iptables to allow the vnc service.
Myself, I'm a noob with iptables and im using a Firestarter GUI.
You can try it or wait for someone with iptables knowledge will answer :)

hazmatt20 07-06-2006 11:28 AM

Well, I do use firestarter, but I think I had opened 5901 already(5900+1 for :1 display). Also, I'm at work connected through ssh for now. I do have a linux box running, so if someone could explain how to get ssh -X to work, that would work as well.

hazmatt20 07-06-2006 02:10 PM

Well, when I tried before, ssh -X did not work. I tried again, and it worked, albeit slowly. However, it was enough to open firestarter to open port 5901 (only 5900 was open). So, I'm set, but what should I have done to change it directly in iptables?

Fadoksi 07-06-2006 02:19 PM

Google revealed me an example command and I think it should be like:

iptables -A INPUT -s sourceip -j ACCEPT -p tcp --destination-port 5900
Not sure will this work but I think it should :) Just change the sourceip

All times are GMT -5. The time now is 08:21 PM.