Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Security
User Name
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.


  Search this Thread
Old 12-11-2008, 11:07 PM   #1
LQ Newbie
Registered: Mar 2005
Posts: 4

Rep: Reputation: 0
Using pam.d to disable KDE/Gnome sessions in the evening

I've been casting around looking for a solution to this...

I need to disable KDE sessions in the evening hours. I was thinking of using dcop to initially lock user sessions, and pam.d to disable unlocking...

I'm thinking there must be an easier way to do this since there are files for kscreensaver and gnome-screensaver in /etc/pam.d

I tried a line in /etc/security/time.conf disabling all services, but it doesn't seem to work for KDE stuff.

Thanks in advance for any help.
Old 12-11-2008, 11:29 PM   #2
Registered: Nov 2007
Location: Pakistan
Distribution: Redhat and Debian
Posts: 302
Blog Entries: 1

Rep: Reputation: 34
you can do it using crontab

chmod 000 /usr/bin/startkde

the original settings are
chmod 755 /usr/bin/startkde
-rwxr-xr-x 1 root root 13277 Nov 17 2006 /usr/bin/startkde
Old 12-11-2008, 11:44 PM   #3
LQ Newbie
Registered: Mar 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks, but that won't work. I need to be able to lock existing sessions, leaving them running, and disable unlocking the screensaver.

Maybe that approach will work though, using dcop to lock. Just need to find & chmod 700 the locking/unlocking bits of the screensavers used in KDE & Gnome, I guess.

In fact, it might have been my approach had I not gone off on my hours-long pam.d tangent.

I may mess around with it. Thanks again.

Last edited by cleger; 12-11-2008 at 11:47 PM.


gnome, kde, login, pamd, screensaver

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to restrict SSH sessions through PAM livetoday Linux - Security 3 04-13-2007 02:46 PM
To disable screensaver in shell sessions grautu Slackware 3 04-12-2007 06:27 PM
How to disable save state across sessions in Gnome? freekamail Linux - Software 2 04-26-2006 09:40 AM
KDE, GNOME sessions has dissapeared... aweir14150 Mandriva 2 03-05-2004 12:33 PM
How to disable the start of KDE/Gnome during boot Chrisser Linux - Newbie 1 09-18-2003 04:56 PM > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 01:14 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration