-   Linux - Security (
-   -   Unable to login as root - system freezes (

rcs1000 07-26-2005 03:34 AM

Unable to login as root - system freezes

I am attempting to login as root (using su - I'm pretty sure I blocked direct login as root). But when I enter my password, the system seems to "hang". Nothing happens. I can CTRL-c to exit su. But I can't login as root.

And this concerns me. Greatly.

I am very worried this is some kind of security issue.

Can anyone help?

Thank you,


(ps - my system is Debian Stable, old version. I've tried logging in as root over the virtual serial line - this is a virtual machine - but the same issue arises.)

Simon Bridge 07-26-2005 04:30 AM

Can you su into another user?

When you try to do something requiring root access from the gui - you get a dialog asking for the root password... does this hang as well?

Normally I would suggest booting from a CD in rescue mode and looking at the root user's configuration. I'm not sure what the virtual machine equivalent is. But I suspect you broke the root user sometime early.

roopunix 07-26-2005 04:44 AM

# chage -l root

what is the output

rcs1000 07-26-2005 05:00 AM

OK - solved for now
Hi all,

Thanks for your help. I tried the nuclear option and "halted" the machine from the admin shell. When the reboot finished I was able to su from my default user.

To secure the box a little I have now prevented any user other than my own from ssh-ing in, and changed the default shells to /bin/false for all except by user.

Hopefully - if this is a security issue - this will solve it. I will look through the logs later and see if there was an attempt on my box.



Krugger 07-26-2005 06:17 PM

Did it work before?

If not, perhaps you need to add your user to the wheel group so he can su.

If yes, can you log as normal root?

All times are GMT -5. The time now is 04:34 AM.