-   Linux - Security (
-   -   Unable to establish NFS share No route to host (

teluguswan 11-24-2009 11:26 AM

Unable to establish NFS share No route to host

I tried and tried but i dont understand where is the problem

I have two systems masternode, node1 they are pinging each other without any problem.

#just for info ----even i installed pdsh

in the masternode i created

vi /etc/exports ---> contents

/cluster *(rw,no_root_squash,sync)

Then i restarted this nfs server by issuing

service nfs restart

Ok upto now this is ok

even iam able to create the same cluser here to here by issuign the following command

mount masternode:/cluster /test

and the output is

FS-Cache: Loaded

and iam seeing the same files which are there /cluster same /test

---------------upto now this is ok with the masternode-------
Now when i tried to run the same from the node1 system

mount masternode:/cluster /node1/test

the error iam getting is

mount: mount to NFS server 'masternode' failed: System Error: No route to host.

---- i issued the same command once again after i disalbed the firewall, selinux by issuing the following commands

service iptables save
service iptables stop

I also disabled the SELINUX=disabled in /etc/selinux/config

and restarted my system to take effect correctly

Now i stopped iptables and selinux

and i tried the same command but still same problem

mount: mount to NFS server 'masternode' failed: System Error: No route to host.

Anyone help what is the problem how can i able to solve this....the network between two is good because iam able to copy files and ping.

sycamorex 11-24-2009 11:33 AM

What's the output of rpcinfo -p server_ip (issued from the client)? It'll give you the idea about the ports the server is using. Make sure that you are using the same ports for rpc services. What distro are you using?

Myiagros 11-24-2009 01:20 PM

What does 'exportfs' return? If it is blank you need to run 'exportfs -arv'

davidstvz 11-24-2009 07:39 PM

I'm mostly a n00b, but I did some nfs stuff the other day and my nfs server start script was called nfs-kernel-server (and there was nfs-common). This probably won't help, but just make sure you did indeed restart the right thing.

The other thing, make sure your node can connect to the Internet and resolve domain names (you can just type "nslookup" at the command prompt and make sure it returns an answer).

fpmurphy 11-25-2009 02:55 AM

portmap and mountd both use TCP Wapppers. If you have a /etc/hosts.allow or /etc/hosts.deny, check the entries in both. If you have a firewall enabled, you need to add rules for portmap (111), 2049 and the various NFS services.

teluguswan 11-28-2009 10:22 PM

I figure out the solution for this is strange.

Always iam trying at the node1 system.

what i figure out here is Iam not doing the same methods and analysis at masternode.

Because the firewall is at masternode this i came to know when i tried with another totally disabled system.

I configured nfs share on that system and accessed successfully from node1....

so i figured out the solution is the masternode is having firewall (I think this is the solution).

Thanks to all once again

All times are GMT -5. The time now is 04:00 AM.