-   Linux - Security (
-   -   Ubuntu 11.04 and Citrix ICA client (

geraldjean 05-04-2011 03:03 PM

Ubuntu 11.04 and Citrix ICA client

I recently updated to Ubuntu 11.04. Result: I can't log on to my company's network with ICA client??? The access is through a Web interface. It worked well with the last 3 or 4 versions of Ubuntu, but not with 11.04. I tried installing the latest version of ICA client but same result. I can logon but when I get to the company's "Application" page and select an application, nothing happens???

If in Firefox I go to Tools>Errors console>
I get the following, translated from French.

Error*: no element found
Source*File :
Line*: 1

Any insights?

Thanks, Gérald

Noway2 05-04-2011 04:44 PM

My immediate guess would be that because Ubuntu 11.04 is based on a the new Unity display system, rather than the traditional Gnome / KDE that this is causing problems with your remote desktop applications. Try launching into classic Ubuntu and see if that makes a difference. This can be done from the login screen.

BTW, is there a security concern with your question or was posting to the LQ Security forum by accident?

geraldjean 05-12-2011 09:55 AM

I am not running the new Unity display system. I chose the "Unbuntu classic" display which uses gnome as GUI.

Could Firefox be at fault? On 11.04 Ubuntu ships with Firefox 4.? while on 10.10 it was Firefox 3.6.

Thanks again for any help,


ahop 05-12-2011 10:06 PM

I am having the same problem. If you find an answer, can you post it here? I'll do the same.

drymnfr 05-14-2011 12:16 AM

I had the same problem on my Ubuntu 11.04 Classic desktop.

It was because firefox 4.0.1 was not configured properly, after upgrading from Ubuntu 10.10 to 11.04.

To resolve this issue,
1) installed the citrix ICA client
2) in firefox -> Edit -> Preferences -> Applications
Select Content Type -> Citrix ICA
Action on mine was "Use Citrix Presentation Server Client for Linux (in Firefox)"
I modified the action to point to /usr/lib/ICAClient/wfica

and I was able to log in to Citrix and use the citrix applications.

If it complains about not trusting certificates, then you should copy the required .crt files to "/usr/lib/ICAClient/keystore/cacerts". If you've been using Citrix before, you should know which crt files are required.

geraldjean 05-16-2011 08:58 PM

Problem solved!
I followed drymnfr suggestions and it worked, first trial!!!

Thanks drymnfr,


All times are GMT -5. The time now is 09:03 PM.