Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Security
User Name
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.


  Search this Thread
Old 07-17-2001, 04:57 PM   #1
LQ Newbie
Registered: Jul 2001
Location: Sunnyvale, CA
Posts: 11

Rep: Reputation: 0
Question Telnet access to RedHat 7.1

I have redhat linux 7.1 and telnet to this machine from network does not work. Have looked into /etc/xinetd.d./telnet and /etc/xinetd.conf nothing seems to be working.

Any help will be appreciated.

thanks ...
... atul
Old 07-17-2001, 10:07 PM   #2
Registered: Jun 2001
Location: Los Angeles, CA USA
Distribution: RedHat
Posts: 53

Rep: Reputation: 15
Ok, so it sounds like telnet is not enabled. You'd probably want to enable it then, assuming you want to use it. Another alternative is sshd.
Old 07-18-2001, 07:43 AM   #3
klaus geld
LQ Newbie
Registered: Jul 2001
Posts: 3

Rep: Reputation: 0
Angry telnet into RH 7.1

Yeah, I am having the same problem at home, along with ftp also. I have had RH 6.1 and 7.0 and have had ftp and telnet services running before.

For RH 7.1
I bought RH 7.1 with a book(RHL 7.1 Secrets, by Naba Barkataki), not a boxed set. I performed the Workstation install class and later had to add the Xinetd rpm(it seems that RH thinks people don't use want these services ?).

Fact: I have looked into the /etc/hosts.allow and the /etc/hosts.deny, both are blank (default for allowing everyone ftp access).

Fact: I have edited the /etc/ file to include the lines that activate ftp and telnet (i.e. ftp stream tcp nowait root /usr/sbin/tcpd in.ftpd -l -a) and the same for telnet.

Fact: I have also modified the /etc/xinetd.d/wu-ftp and /etc/xinetd.d/telnet file to get ride of the line " disable = yes". If I recall correctly, this disable line was not there before? but I found it nonetheless and deleted it.

Fact: The telnet and ftp (server and client), and xinetd server rpms are installed(they are not by default in the workstation install option).

Fact: ps -ef | grep net gives "xinetd -stayalive -reuse -pidfil"

Fact: I got ride of all of the ipchains rules for now. I had originally installed the firewall as "high security" but yet chose to allow HTTP, ftp, telnet and ssh. Later I reinstalled and chose "medium security" and still allowed the incoming internet services ftp, telnet etc.

Fact: I open a terminal window as root and telnet or ftp my own ip and and both give me "connection refused".

I have not yet installes the ssh client, but something tells me this problem is system wide.
Old 07-18-2001, 11:57 AM   #4
LQ Newbie
Registered: Jul 2001
Location: Sunnyvale, CA
Posts: 11

Original Poster
Rep: Reputation: 0
Ok!! I am not that familiar with firewall part of story. I believe that is was installed as being "low security". BTW, I have not installed this machine.

and I can successfully do telnet localhost and it works like a champ. I can even login as root when I can do telnet localhost.

I do not know if this helps ...

thanks anyway for the responses...
Old 07-23-2001, 11:38 AM   #5
Registered: Apr 2001
Location: Brisbane, Australia
Distribution: Ubuntu
Posts: 146

Rep: Reputation: 15
Have a look at both the telnet and ftp files in the /etc/xinetd.d directory.

Check them for the line only_from = ..., if it's there delete it.
Old 07-23-2001, 01:21 PM   #6
LQ Newbie
Registered: Jul 2001
Location: Sunnyvale, CA
Posts: 11

Original Poster
Rep: Reputation: 0
I found out guys, Thanks for your help anyway.

The telnet access was being blocked by the firewall. Ipchains is the command. I had to flush the IP routing table entries.

and it now works like a champ.

Thanks for your anyway, everybody.
Old 09-26-2001, 05:09 PM   #7
LQ Newbie
Registered: Sep 2001
Location: England
Distribution: Redhat 7.1
Posts: 1

Rep: Reputation: 0
Thank you all for your help, the solution (ipchains --flush) worked for me also.

From a Linux Newbie, rapidly becoming a Linx convert.
Old 10-05-2001, 11:32 AM   #8
Registered: Oct 2001
Distribution: Ubuntu 9.10
Posts: 148

Rep: Reputation: 15
why use something as unsafe as telnet and ftp? You really might as well shut down your firewall, cause if someone sees ports 21 and 23 open, they will go for it. Red Hat installs and opens SSH by default which is much safer.
Old 11-03-2001, 08:56 PM   #9
LQ Newbie
Registered: Nov 2001
Posts: 3

Rep: Reputation: 0
To klaus geld

Were you able to get your Telnet & FTP working? I'm facing the same problem as you after installing publisher's edition of RH 7.1 from Mastering Red Hat Linux 7.1 book.
Old 11-04-2001, 11:12 AM   #10
Registered: Jul 2001
Location: Taiwan (ex-Victoria BC)
Distribution: RH 9.0
Posts: 126

Rep: Reputation: 15
Y'all may want to take a look at the command 'chkconfig' which, when typed with this option:

chkconfig --list |less

will show you all services currently running. To turn telnet on, type:

chkconfig telnet on

Although, personally I avoid telnet like the plague and only ever use ssh.
Old 11-13-2001, 04:34 AM   #11
Registered: Nov 2001
Distribution: Redhat 7.0 ,mandrake 8.0 ,Redhat 7.2
Posts: 99

Rep: Reputation: 15
u better get a newer version of xinetd .i had the same problems .i got xinted.*pre-10 from provide a perl script which reads ur inetd.conf file and creates an xinetd.conf file ...i found that it worked.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP and Telnet Access Flossie Mandriva 5 10-23-2003 11:37 AM
root access via telnet Goma_2 Linux - General 3 10-03-2003 09:13 AM
Telnet Access Ganeshmanus Linux - Networking 15 08-01-2003 02:00 PM
Root Telnet Access AtulGore Linux - Networking 5 11-21-2001 11:32 PM
Telnet Access Restriction mocha Linux - Networking 1 09-16-2001 02:17 PM > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 09:22 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration