-   Linux - Security (
-   -   sudo not setting defaults (

brainlesspinkey 09-10-2005 01:22 PM

sudo not setting defaults
I am having a wierd probem with sudo:
I am trying to make the passwd time out for sudo. The default is set to infinate. I try to reset this with:
Defaults passwd_timeout=1
but, there is no difference.

What is going on? Is this a bug? I'm using debian unstable.


Matir 09-10-2005 01:58 PM

According to the sudoers man page, the default is 5 minutes. Your syntax appears correct to me. What occurs when you attempt to use sudo with this?

brainlesspinkey 09-10-2005 02:59 PM

My man file says the default for passwd_timout is: "the default is 0, set this to 0 for no password timeout"

When I use sudo without trying to set the passwd_timeout, it doesn't timeout, like the man page says. When I try to set the timeout to 1 min, with the code in my first post, the behavior doesn't seem to change
I use sudo, and it prompts for the password. Then I wait 10 minutes. I use sudo again, and it won't prompt for any password. Happens on both settings.

Here is the rest of my sudoers file, if that helps:


Defaults  passwd_timeout=1
root ALL=ALL
pinkey  ALL = (root)ALL

Thanks for the help so far.

brainlesspinkey 09-11-2005 01:56 AM

I figured it out... The proper setting I should use to get the behaviour I wanted is "timestamp_timeout"
urg, I'm such a noob.

Matir 09-11-2005 12:34 PM

Interesting. I don't think you're such a noob as I missed it in the man page myself when looking at passwd_timeout.

All times are GMT -5. The time now is 04:34 AM.