LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Security (https://www.linuxquestions.org/questions/linux-security-4/)
-   -   setfacl: Operation not supported (https://www.linuxquestions.org/questions/linux-security-4/setfacl-operation-not-supported-641085/)

nekton 05-09-2008 01:26 PM

setfacl: Operation not supported
 
OS: Centos-5 x64

Problem: I cannot get setfacl to work on my box.

setfacl: /var/www/vhosts/domain.com: Operation not supported

Troubleshooting steps:

1. Viewed default mount options on the / directory (dev/sda1) via "tune2fs -l /dev/sda1 | grep options"

[root@domain.com ~]# tune2fs -l /dev/sda1 | grep options
Default mount options: (none)

2. Viewed fstab:

[root@domain.com ~]# more /etc/fstab
/dev/sda1 / ext3 defaults 1 1
/dev/sda2 swap swap defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm mpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0

3. Modified fstab and rebooted. Now it looks like this:

[root@domain.com ~]# more /etc/fstab
/dev/sda1 / ext3 user_xattr acl 1 1
/dev/sda2 swap swap defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0

4. No change in default mount options, though:

[root@domain.com ~]# tune2fs -l /dev/sda1 | grep options
Default mount options: (none)

5. Setfacl still not working
[root@z ~]# setfacl -m u:user1:rwx /var/www/vhosts/domain.com/httpdocs
setfacl: /var/www/vhosts/domain.com/httpdocs: Operation not supported

Thanks in advance for your help, ppl!

nekton 05-09-2008 02:57 PM

OK, solved my problem. The issue was that I had to add "defaults" as well as acl and user_xattr the mount line on fstab, like so:

/dev/sda1 / ext3 defaults,acl,user_xattr 1 1


All times are GMT -5. The time now is 07:45 AM.