LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices


Reply
  Search this Thread
Old 01-12-2005, 06:53 AM   #1
jferrando
LQ Newbie
 
Registered: Dec 2004
Location: Vila-real (Spain)
Distribution: DEBIAN, MANDRAKE, SUSE
Posts: 11

Rep: Reputation: 0
Set umask for user in KDE


I am using Mandrake 10.1+KDE. Every time I log in as my user, the umask is 0022. I have tried to set it in .bash_profile and in .profile the mask 0007, but it does not work, every time I log in again the mask is 0022, and with files created with Konqueror file explorer it happens the same.
 
Old 01-12-2005, 10:39 AM   #2
jferrando
LQ Newbie
 
Registered: Dec 2004
Location: Vila-real (Spain)
Distribution: DEBIAN, MANDRAKE, SUSE
Posts: 11

Original Poster
Rep: Reputation: 0
Found but only in bash-mode

Ok, I have my answer, so, here it is:

In the file /etc/sysconfig/msec, have replaced the UMASK_USER
UMASK_ROOT=022
SECURE_LEVEL=2
UMASK_USER=007
TMOUT=0

This creates files with mask rw-rw---- in bash-mode, but when using Konqueror as the file manager, it now creates files with rw-rw-r-- (664) mode, not 660 as it sould be. Any ideas?
 
Old 01-12-2005, 11:41 AM   #3
jferrando
LQ Newbie
 
Registered: Dec 2004
Location: Vila-real (Spain)
Distribution: DEBIAN, MANDRAKE, SUSE
Posts: 11

Original Poster
Rep: Reputation: 0
Solved in Mandrake 10.1!

Ok, this is the answer for both bash (xterminal) and Konqueror

Go to the "MandrakeLinux Control Center"
Select "Security" - "Levels and Checks" (or something similar, I am using Spanish) - "System Options", and type
Root mask 0027 (or whatever)
User mask 0007 (or whatever)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ProFTPD: Set umask so that directories are created with 'sticky bit' on. dutch2005 Linux - Software 1 09-06-2005 06:06 AM
How to set umask value to 0007 cbekannan Linux - Security 4 01-11-2005 01:15 AM
How to set defaul UMASK 037 sbrewer Linux - Software 2 09-15-2004 01:26 PM
can you set a default umask for only certain directories? BrianK Linux - General 3 06-14-2004 10:02 PM
Where to set default file permissions (umask)? tredegar Linux - Newbie 14 01-27-2004 06:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 12:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration