LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices


Reply
  Search this Thread
Old 09-13-2004, 04:48 PM   #1
Durham
Member
 
Registered: Feb 2002
Distribution: Debian, Ubuntu, Clonezilla, Knoppix, Kubuntu
Posts: 46

Rep: Reputation: 16
Screen energy saver increases ping replytime on FW


I've had two Coyote Firewall's running with no problems for one year now, but last week they suddenly started acting a bit strange. Surfing Internet i “slooooow”, and ping reply time is also slow. I have'nt made any changes in my setup that can explain this behavior.

My networks
--------------------------------

First I have a RadiolinkRouter, then I have a 5P switch with cables to my two CoyoteLinux FW's and one cable that goes to a fiberconverter. (at the end of this cable there is one single Win98 PC) Behind each of my two CoyoteFW's I have a Debian GNU/Linux server, and a lot of thin clients.

My main problem is that the internet connection is slow.


My observations
--------------------------------
- Normal ping reply time from each of my servers, to the outside of the RadioLink Router is about 1.0ms When the reply time is at this level, the internet connection is OK. (4 Mb/s)
- After 15 min the screen energysaver on my FW's kicks in. Suddenly the ping reply time increases to 20-22ms, and the internet connection speed decreases to 0.7Mb/s. When I hit the space-bar on a FW to deactivate the energysaver, the ping reply time jumps form 22ms to 1.0ms

My first taught was that the FW's NIC's was broken, but I think that it's a bit to strange that this should occur at the same time on two separate FW's

When I give the command ifconfig on one of my FW's, this is the result:

coyote# ifconfig
eth0 Link encap:Ethernet HWaddr 00:14:AB:05:FD:40
inet addr:10.0.2.1 Bcast:10.0.3.255 Mask:255.255.254.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1110226 errors:0 dropped:0 overruns:0 frame:0
TX packets:1075681 errors:0 dropped:0 overruns:0 carrier:0
collisions:2065 txqueuelen:100
RX bytes:4073725 (3.8 MiB) TX bytes:17029612 (16.2 MiB)
Interrupt:11 Base address:0x300

eth1 Link encap:Ethernet HWaddr 00:20:08:6E:7C:0E
inet addr:10.9.0.45 Bcast:10.9.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1998308 errors:14380 dropped:0 overruns:2052 frame:2052
TX packets:1052034 errors:0 dropped:0 overruns:0 carrier:0
collisions:3058 txqueuelen:100
RX bytes:1107048043 (1007.6 MiB) TX bytes:3269417 (133.1 MiB)
Interrupt:10 Base address:0x210

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:308 errors:0 dropped:0 overruns:0 frame:0
TX packets:308 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 iB) TX bytes:0 (0.0 iB)
coyote#


On eth1 there are a lot of errors, almost 1% of the total of RX packets. What could be the reason for this?

Anyone who have an idea about what this is about?
OK. I will put in a newer version of CoyoteLinux, and on another piece of HW. But I would like to find out what is happening, and why. As said before, this happened on two FW's at the same time.

Any comments or suggestions would be appreciated
 
Old 09-13-2004, 08:53 PM   #2
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 69
Check your memory and CPU loads. Screensavers can be notorious resource hogs, so you might just have maxed out the system resources and started dropping packets. Offhand I don't know of a straight-forward way to do that with the screensaver on, but you could use a simple script to check resources every ~5s and append the output to a file. Then just run the script, fireup your screensaver and check the file once you start dropping packets.
 
Old 09-14-2004, 02:49 PM   #3
Durham
Member
 
Registered: Feb 2002
Distribution: Debian, Ubuntu, Clonezilla, Knoppix, Kubuntu
Posts: 46

Original Poster
Rep: Reputation: 16
It's not the screen saver that starts, but the energy saving function.
This is controlled by the bios. After 15 minutes of inactivity, the
screen is set to standby mode. I don't think this need CPU or RAM
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI 9200 SE screen flicker in screen saver gargamel Slackware 12 07-09-2005 05:10 PM
screen saver goes off and screen goes black Doug.Gentry SUSE / openSUSE 2 03-26-2005 06:08 PM
How to turn off screen blanking screen saver in run level 3? Arodef Linux - Software 1 01-04-2005 01:50 PM
enabling energy saver mode for monitor blackpacu Linux - General 5 01-29-2004 09:52 AM
Disabling screen / energy saver vinny Linux - General 3 10-31-2002 11:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 06:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration