LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices


Reply
  Search this Thread
Old 07-17-2004, 12:57 PM   #1
Israfel2000
Member
 
Registered: May 2004
Location: Underground base in the mountains
Distribution: FreeBSD, Fedora, Ubuntu
Posts: 87
Blog Entries: 2

Rep: Reputation: 18
problem with iptables


I have just installed iptables-1.2.11 on my Red Hat Linux 9 box. I extracted it and it went well. I did the "make" command in the KERNEL_DIR=(where-my-kernel-is) where it instructs me to put it and it went well. Also the "make install" command. But, when I put in 'iptables (options)' on the terminal it gives me this:

bash: iptables: command not found

I am very confused I don't know what went wrong. I would greatly appreciate your help. Thanks in advance.
 
Old 07-17-2004, 01:43 PM   #2
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 69
1. Make sure you are root when trying to use the iptables command

2. Make sure you are entering the command properly (in-correct syntax can cause iptables to return a similar message (post the rule your trying to add)

3. Make sure that iptables installed properly

4. Make sure that your kernel has support for iptables and all necessary modules are loaded (lsmod)

Last edited by Capt_Caveman; 07-17-2004 at 01:44 PM.
 
Old 07-17-2004, 01:48 PM   #3
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
check that the iptables binary is in your PATH. try running

/sbin/iptables

instead of plain "iptables"
 
Old 07-18-2004, 12:30 AM   #4
Israfel2000
Member
 
Registered: May 2004
Location: Underground base in the mountains
Distribution: FreeBSD, Fedora, Ubuntu
Posts: 87

Original Poster
Blog Entries: 2

Rep: Reputation: 18
Thx guys. Thanks for both of your help. I needed to add the "/sbin" before the "iptables" command.

Now, it's time for me to get back to work. Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem iptables stomach Linux - Software 3 09-22-2005 02:21 PM
problem with iptables bladrag Linux - Networking 2 03-24-2004 03:08 PM
iptables problem bhagat_panwar Linux - Software 0 08-27-2003 06:45 AM
iptables problem? poulaum Linux - Networking 12 02-27-2003 03:57 PM
Problem with IPTABLES jfall Linux - Networking 3 11-04-2002 03:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration