LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices


Reply
  Search this Thread
Old 11-27-2004, 07:00 PM   #1
tamuct
LQ Newbie
 
Registered: Nov 2004
Distribution: FC3
Posts: 2

Rep: Reputation: 0
Question passwd fails when trying to change user passwords


When I try to use passwd to change a user's password I get the following result every time:

[root@www ~]# passwd username
Changing password for user username.
New UNIX password:
Retype new UNIX password:
passwd: Authentication failure
[root@www ~]#

This only occurred after I upgraded from FC2 to FC3 and migrated all my /etc/passwd and /etc/shadow over from backups I had.

What is wrong? I think it's something with PAM, but I'm not sure. Every user has a /etc/passwd and /etc/shadow entry. authconf is setup to use MD5 and Shadow passwords only.
 
Old 12-04-2004, 11:24 PM   #2
christian.vrl
LQ Newbie
 
Registered: Nov 2003
Location: Fortaleza - CE - Brazil
Distribution: CentOS
Posts: 7

Rep: Reputation: 0
the same occurs to me in a flesh install. I still have no clue what's going on here
 
Old 12-05-2004, 02:23 AM   #3
tamuct
LQ Newbie
 
Registered: Nov 2004
Distribution: FC3
Posts: 2

Original Poster
Rep: Reputation: 0
FC3 passwd Authentication issues

I finally gave up on it and went back to FC2. Everything works fine, now.

Another problem with FC3 I ran into was with my USB HP DeskJet 960c. After installing the latest kernels for FC3, it would hang on kudzu during bootup. Anyone else had similar problems with FC3?
 
Old 12-07-2004, 12:24 PM   #4
alleycat
LQ Newbie
 
Registered: Jun 2004
Location: Chicago, IL
Distribution: fedora / centos / rhel
Posts: 12

Rep: Reputation: 0
fwiw, if you turn off selinux in the system-config-securitylevel applet and reboot, it works. alternatively, you can put selinux=0 on the kernel line in /etc/grub.conf

unfortunate, but i get the impression that selinux polices aren't quite cooked for general usage yet.
 
Old 12-07-2004, 01:12 PM   #5
christian.vrl
LQ Newbie
 
Registered: Nov 2003
Location: Fortaleza - CE - Brazil
Distribution: CentOS
Posts: 7

Rep: Reputation: 0
I'm not infront of the machine right now, but my selinux is set to warm only. Also, I installed a few minutes ago Webmin and I was able to change the passwords throw webmin.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable passwd change for user account sodhilogin Linux - General 6 09-01-2004 01:43 AM
giving user ability to change all users passwords mp5 Linux - Newbie 1 06-28-2004 09:02 PM
Reading the passwd passwords BoldKiller Programming 2 05-22-2004 12:07 AM
Is there a way to sync Samba passwords with linux user passwords MarleyGPN Linux - Networking 2 09-09-2003 11:59 AM
user can change passwd kelper Linux - Software 3 08-28-2003 05:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 03:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration