-   Linux - Security (
-   -   PAM User Login Authentication Failure (

robeb 11-15-2002 12:50 AM

PAM User Login Authentication Failure
I have box at school that is being used by students to do labs. With new accounts I issue them a passwd and then use chage to set the passwd expiration date to a past date so that when they login they have to change their passwd.

I setup a new box today with some new user and when I tried to login with a dummy account I got this error when I tried to login...

Nov 14 10:21:26 host sshd(pam_unix)[16491]: authentication failure; logname=user uid=0 euid=0 tty=/dev/pts/3 ruser= rhost=host user=user

To setup the accounts with chage I did...

chage user
mim passwd age: 0
max passwd age:30
last passwd change: 2002-01-01
exp warning: 7
passwd inactive: -1
account inactive: 2003-01-01

chage -l user show this...
mim: 0
max: 30
warning: 7
inactive: -1
last change: 2002-01-01
passwd expires: 2002-01-31
passwd inactive: never
account expires: 2003-01-01

I'm not really familiar with PAM and I've never had this problem before. Does anyone have an idea what might be going on?

markus1982 11-15-2002 01:43 AM


passwd expires: 2002-01-31
Password is expired ...

robeb 11-15-2002 01:56 AM

Yes, yes...but when you login it asks for a new password and then after entering the passwd for the first time (it's ask you again to confirm) the user is dropped.

This is suppose to be a trick that you can use so you can issue a passwd to a user and then when they login they have to enter a new passwd. This has worked for me in the past on a different box.

unSpawn 11-15-2002 01:01 PM

Hmm. Can you tell us if you're working with different Sshd versions? I've read sshd->pam is a wee bit b0rken in v3.x
Btw, did you try a diff between the /etc/pam.d dirs?

robeb 11-16-2002 06:00 PM

I'm using open-ssh-3.4 on my box and my users putty to login. Mmm....broken you say? Would you indulge me further and explain what you mean by the second part of your question?

unSpawn 11-16-2002 09:01 PM

I just wanted to know if both your /etc/pam.d tree's where different, that's all. Btw, did you try verbose logging? Modules in the stack usually will take "debug" as argument.

Another clarification: I *thought* I read some stuff on a mailinglist a while ago about some interaction between Sshd and PAM being b0rken (PAM side), can't remember tho what it exactly was except it was some really minor glitch.

All times are GMT -5. The time now is 03:03 PM.