-   Linux - Security (
-   -   non-root users can't log in (RH9) (

skullmunky 11-17-2004 11:06 AM

non-root users can't log in (RH9)
i have a lab of RH9 machines that have been working fine for close to 2 yrs; suddenly, on several machines, non-root users can't log in. users are networked, so first tried disabling NIS on the client in question and created a local user acct. to try out. no luck there, so I think i can rule out network-related problems.

login doesn't produce an error, just instantly returns back to the login screen. in /var/messages, i see:

session opened for user localtest by LOGIN (uid=0)

but no errors after that.

i checked /etc/pam.d/login and system-auth; these are identical to the files on other (working) machines, and nothing immediately weird.

is there any way to make login or PAM produce more error output instead of silently failing? i tried putting in the 'debug' arg into system-auth, but didn't see anything more in /var/log/messages or /var/log/secure.

i'll probably just wipe these and reinstall, but i'm still curious ...


qwijibow 11-17-2004 11:41 AM

its been a whie since i used redhat 9... but try looking for the boot script that runs the loggin programs on he console, and making it run through strace. maybe strace's output file may point you in the right direction.

so it suddenly stoped working for no reason ?
you didnt update or change anything ?

could the boxes have been compromised ?

All times are GMT -5. The time now is 11:22 PM.