-   Linux - Security (
-   -   Jail and chroot (

rogk 10-15-2005 03:36 AM

Jail and chroot

I used this tutorial to install Jail to my Gentoo -> I tried it few times. Those base commands like cp,mkdir,vi etc. worked well. But with irssi I got this error "setupterm() failed for TERM=xterm: 0 Can't initialize screen handling, quitting." and more "You can still use the dummy mode with -d parameter". If I'll try "irssi -d" then I'll get "Can't open perl script "-e": Permission denied".
And with "screen" I get error "Must be connected to a terminal.". I hope that somebody could help with these informations.

unSpawn 10-15-2005 07:02 AM

See if copying the /usr/share/terminfo/x dir to the jail helps.

rogk 10-16-2005 02:20 AM

Thank you, but not helped. Screen gives me error "Must be connected to a terminal." and irssi "Can't open perl script "-e": Permission denied" and this "Segmentation fault (core dumped)". There is no X in the Gentoo.
I have tried with google, but I haven't got solved these problems. I hope that somebody who has done chroot before could help me with this. The tutorial, which I mentioned above, was little bit sort and I haven't found better one.

All times are GMT -5. The time now is 03:47 AM.