-   Linux - Security (
-   -   ID created with assigned group is not display in /etc/group file (

dwarf007 08-19-2007 12:02 PM

ID created with assigned group is not display in /etc/group file
Every time I created ID in the servers and when the ID is assigned with few groups. The groups will display while I tried to check with "id -a username"

When I tried to check the assigned group in /etc/group file, I found the ID only display in one of the group. Where the ID does not display in the in other groups.

Does anyone know why? Appreciate someone can help on this.

stress_junkie 08-21-2007 05:38 PM

Each user group has only one record in the /etc/group file. Is that what you mean? I don't really understand your question. It sounds like you are asking why each user group only has one entry in the /etc/group file.

If you want to know which groups are assigned to a specific user account you can either log in as the user and enter the groups command, or you can use grep to search for the user account name in the /etc/group file.

You should find someone who can speak English a lot better than you can and get them to help you write your question.

dwarf007 08-21-2007 10:39 PM

Example ID created as below
username: abc
groups: group1, group2, group3

# id abc
uid=300(abc) gid=500(group1) groups=501(group2),502(group3)

While I check on /etc/group

Does anyone know why the user ID abc does not shows in group2 and group3 in /etc/group

All times are GMT -5. The time now is 08:09 AM.