-   Linux - Security (
-   -   ICQ trouble on SuSE Linux 10.1 (iptables aka SuSEfirewall2?) (

spocksbrain 11-02-2006 12:00 PM

ICQ trouble on SuSE Linux 10.1 (iptables aka SuSEfirewall2?)
Hi everybody,

To access the internet from several clients I set up a router/server that used to be running SuSE 9.0 until recently. For some reasons I had to upgrade it to SuSE 10.1 this week. While the transition seemed to go smoothly, there is one problem with SuSEfirewall2 as it seems. I can no longer connect to ICQ or AIM. The settings used with SuSEfirewall2 have not changed (I copied them over from the SuSE 9.0 installation and later rewrote them from scratch - to no avail) and neither have the clients changed in any way. Strangely enough, I don't seem to be able to find anything on this matter on the internet, either.

Instant messaging services that still work include Jabber, Skype, Yahoo, and MSN. ICQ and AIM are down. However, when I try to connect to ICQ, other users see me listed as online, but my client still doesn't connect.

What has changed with the SuSEfirewall2 from SuSE 9.0 that causes this problem?

Is anybody out there using a similar configuration without any ICQ trouble?

Any help would be greatly appreciated!!!


unSpawn 11-04-2006 09:52 AM

Best would be to wedge in some "-j LOG" target rules on where "-j DROP" packet decisions are made. That way it will be easier to determine what's missing in the ruleset.

spocksbrain 11-06-2006 11:36 AM

New twist
Thanks for your reply. Actually I tried several things over the weekend without any success though.

However, today I had a chance to try one of my clients on a different LAN. To my astonishment ICQ would not work there, either, not even on clients indigeneous to that LAN which used to be working previously. Thus, I am afraid it was not SuSEfirewall2 in the first place, but rather a change in the ICQ protocol that was introduced on exactly the same day as I upgraded my server/router (ugh!). :cry:

Now the new question is, has anyone else had the same problem using Kopete (I got 0.11.1) and is there a solution to this problem? :confused:

All times are GMT -5. The time now is 02:25 PM.