LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Security (https://www.linuxquestions.org/questions/linux-security-4/)
-   -   .htaccess (https://www.linuxquestions.org/questions/linux-security-4/htaccess-1343/)

bretthoward 03-16-2001 04:02 AM

For some reason I can't get .htaccess to work anymore after upgrading apache. Im running 1.3.17 and it still has the section that tells it to use the .htaccess files in the httpd.conf file. The contents of my .htaccess file is as shown below:

AuthUserFile /home/httpd/cgi-bin/x10/.htpasswd
AuthGroupFile /dev/null
AuthName X10 Password Authentication
AuthType Basic
require valid-user

and I have added a user into my .htpasswd file but when I load the page in this folder it loads with out any password prompts like I used to get before upgrading. Any Ideas?

nedo 03-23-2001 09:48 AM

i guess all you need to place in a .htaccess file is
require valid-user
anything else goes to httpd.conf ( did you enable Auth in httpd conf?)

bretthoward 03-23-2001 04:27 PM

No I don't beleve that I did if it wasn't a default configuration... What does the tag that needs to be set look like cause I don't particularily remember an auth setting... But it is a pretty big file!

nedo 03-24-2001 03:03 AM

In 1.3.12 you needed to place line like this in httpd.conf

<Directory />
Options FollowSymLinks
AllowOverride AuthConfig
</Directory>

This sets default mode for all the directories.
AuthConfig is required for .htaccess to work

next you might want to create a similar tag for any directory you want to share using your apache and add more AllowOverrides like ExecCGI
I guess Apache manual tells you everything.
What's the big difference between 1.3.17 and 1.3.12 ?

bretthoward 03-24-2001 04:21 AM

They said mainly it was just bug fixes... the folder I am doing this to is under cgi-bin so I may have to change that in a few places but I hope I'll figure it out

rebby 04-02-2001 03:33 PM

Did you get this to work???

This may help some....

http://linux.rebby.com/apache/secure.html


All times are GMT -5. The time now is 07:08 AM.