-   Linux - Security (
-   -   Giving Kppp rights to other users n groups (

xxx_anuj_xxx 12-19-2004 04:45 AM

Giving Kppp rights to other users n groups
I am using kppp (Redhat el) for connecting to the net and everytime it asks for the root password. How to give kppp rights to other users and groups so that they can use dialup without giving root password?:(

mjrich 12-19-2004 02:03 PM

Make sure that the users are (at least) members of the groups dip, dialout, and tty.



xxx_anuj_xxx 12-21-2004 01:30 AM

First of all Thankyou mj for your help, I tried this thing (making the user a memebr of dip, dialout, and tty.)Here i don't have this group named dialout. Furthermore I tried the same thing after making him (user) a memeber of all other groups didn't worked.
Please give some other idea.. and what is this group dialout?it's not here ...may be this is the perob here
Thankyou friend!

mjrich 12-21-2004 03:57 PM

It seems that there are three options - edit /etc/pam.d/kppp and change the following:

#auth sufficient /lib/security/
auth  sufficient /lib/security/

Or, you can run <usernetctl> and set "USERCTL=true" in /etc/sysconfig/network-scripts/ifcfg-pp. Lastly, you can either set kppp to suid, or create a dialout group and a kppp.allow file in /etc, as suggested by this post



xxx_anuj_xxx 12-22-2004 03:13 AM

:)Thanks a lot dear friend mj!
I got another solution too ...seems like now two solutions are available...
here i tried this thing which is working perfectly ...
Try the following:

1. rm /usr/bin/kppp
2. chmod u+s /usr/sbin/kppp
3. ln -s /usr/sbin/kppp /usr/bin/kppp

The first line removes a symbolic link to the real binary. The second line changes the permissions on kppp so that it will run as root no matter what user runs the program. The last line re-creates the link that you removed in the first step. The net effect is that the binary runs as root, no matter what the UID of the user running the program. This means that you don't have to supply a root password.

after this only ting which i neede was to reconfig my kppp .
Thank you mj for your help:)

:) :) :)

mjrich 12-22-2004 07:12 PM

No worries :)



All times are GMT -5. The time now is 08:09 PM.