LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices


Reply
  Search this Thread
Old 12-14-2015, 06:23 AM   #1
packets
Member
 
Registered: Oct 2005
Posts: 324

Rep: Reputation: 32
firewalld port forwarding sometimes not working


I have configured firewalld to port forwarding. Below are my config:

Code:
# firewall-cmd --zone=public --list-all
public (default, active)
  interfaces: eth0
  sources:
  services: dhcpv6-client ssh
  ports: 25/tcp 25/udp 26/tcp
  masquerade: yes
  forward-ports: port=26:proto=tcp:toport=8026:toaddr=X.X.X.X
        port=25:proto=tcp:toport=8025:toaddr=X.X.X.X
  icmp-blocks:
  rich rules:
I am testing port forwarding by doing telnet to port 25 in a matter of seconds

telnet X.X.X.X 25 --> ok
after 1 second
telnet X.X.X.X 25 --> ok
after 1 second
telnet X.X.X.X 25 --> ok
after 1 second
telnet X.X.X.X 25 --> not responding
after 60 seconds
telnet X.X.X.X 25 --> ok

So in short it is intermittent. Is there a config settings that causing this behavior? Tried to check /etc/firewalld/firewalld.conf but I did not see any related settings.

Anyone knows if this is the normal behavior of port forwarding of firewalld
 
Old 12-15-2015, 06:49 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,393
Blog Entries: 55

Rep: Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565Reputation: 3565
AFAIK firewalld only produces iptables rule sets, nothing else. So if there's problems you IMHO should be analysing them like you would troubleshoot any other regular network (device) problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
port forwarding? not working :( shievelet Linux - Networking 5 03-11-2007 02:56 PM
Port Forwarding is not working. Blitza Linux - Networking 3 12-11-2006 04:03 AM
Port forwarding not working bulliver Linux - Networking 5 03-24-2006 06:05 PM
port forwarding? not working?... snip128 Linux - Networking 1 10-07-2005 10:49 AM
port forwarding NOT working :( Avatar Linux - Networking 19 04-23-2004 02:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 08:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration